summaryrefslogtreecommitdiff
path: root/gnu/packages/php.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-10-29 22:06:02 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-10-30 09:51:38 +0100
commit697d2e037bc999760b85b7904079679e0ccc1e62 (patch)
tree53e90b6f16a58aa52cfeaf8fa496f6982794f1d5 /gnu/packages/php.scm
parentf00ccdcb9b8de6e856543d150a8e387818400c58 (diff)
downloadguix-patches-697d2e037bc999760b85b7904079679e0ccc1e62.tar
guix-patches-697d2e037bc999760b85b7904079679e0ccc1e62.tar.gz
gnu: php: Update to 7.4.12 [security fixes].
* gnu/packages/php.scm (php): Update to 7.4.12. [arguments]: Disable two more failing tests.
Diffstat (limited to 'gnu/packages/php.scm')
-rw-r--r--gnu/packages/php.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index 9e34811969..835ce5c884 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -60,7 +60,7 @@
(define-public php
(package
(name "php")
- (version "7.4.11")
+ (version "7.4.12")
(home-page "https://secure.php.net/")
(source (origin
(method url-fetch)
@@ -68,7 +68,7 @@
"php-" version ".tar.xz"))
(sha256
(base32
- "1knnw9b5hkxmisxclw384ic6bcihihhii51q0fyva8cwkdd6fcax"))
+ "0xkbx7ykjlkv8p1an342am4j0d633dbf5x1ggmmmy985mp72nbg8"))
(modules '((guix build utils)))
(snippet
'(with-directory-excursion "ext"
@@ -312,6 +312,10 @@
"ext/standard/tests/file/bug43008.phpt"
;; Table data not created in sqlite(?).
"ext/pdo_sqlite/tests/bug_42589.phpt"
+ ;; Expects an Array with 3 preg_matches; gets 0.
+ "ext/pcre/tests/bug79846.phpt"
+ ;; Expects an empty Array; gets one with " " in it.
+ "ext/pcre/tests/bug80118.phpt"
;; This tests whether microseconds ‘differ enough’ and
;; fails inconsistently on ‘fast’ machines.