summaryrefslogtreecommitdiff
path: root/gnu/packages/php.scm
diff options
context:
space:
mode:
authorBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2019-11-10 22:19:09 +0100
committerBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2019-11-16 18:00:24 +0100
commit30502f1dd6969a187abf98dd59fa84ee40284cef (patch)
treebab76b23cebb6a56230e1d2c4ce1005078e4540b /gnu/packages/php.scm
parenta9b15d4c7f7bb8e830ed1112a6cabfb2cb9d2077 (diff)
downloadguix-patches-30502f1dd6969a187abf98dd59fa84ee40284cef.tar
guix-patches-30502f1dd6969a187abf98dd59fa84ee40284cef.tar.gz
php: Enable more extentions.
* gnu/packages/php.scm (php)[arguments]: Use libzip instead of zip for the "--with-libzip" argument, enable intl and zip. [inputs]: Add icu4c, libzip. Remove zip.
Diffstat (limited to 'gnu/packages/php.scm')
-rw-r--r--gnu/packages/php.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index b144a6b26a..bc60539fb4 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -36,6 +36,7 @@
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages icu4c)
#:use-module (gnu packages image)
#:use-module (gnu packages linux)
#:use-module (gnu packages multiprecision)
@@ -101,7 +102,7 @@
(with "--with-jpeg-dir" "libjpeg")
(with "--with-ldap" "openldap")
(with "--with-ldap-sasl" "cyrus-sasl")
- (with "--with-libzip" "zip")
+ (with "--with-libzip" "libzip")
(with "--with-libxml-dir" "libxml2")
(with "--with-onig" "oniguruma")
(with "--with-pcre-dir" "pcre")
@@ -136,9 +137,11 @@
"--enable-fpm"
"--enable-ftp"
"--enable-inifile"
+ "--enable-intl"
"--enable-mbstring"
"--enable-pcntl"
- "--enable-sockets"))
+ "--enable-sockets"
+ "--enable-zip"))
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'do-not-record-build-flags
@@ -356,6 +359,7 @@
("glibc" ,glibc)
("gmp" ,gmp)
("gnutls" ,gnutls)
+ ("icu4c" ,icu4c)
("libgcrypt" ,libgcrypt)
("libjpeg" ,libjpeg)
("libpng" ,libpng)
@@ -364,6 +368,7 @@
("libxpm" ,libxpm)
("libxslt" ,libxslt)
("libx11" ,libx11)
+ ("libzip" ,libzip)
("oniguruma" ,oniguruma)
("openldap" ,openldap)
("openssl" ,openssl)
@@ -372,7 +377,6 @@
("readline" ,readline)
("sqlite" ,sqlite)
("tidy" ,tidy)
- ("zip" ,zip)
("zlib" ,zlib)))
(native-inputs
`(("pkg-config" ,pkg-config)