summaryrefslogtreecommitdiff
path: root/gnu/packages/php.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-01-16 20:26:50 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-01-16 20:35:41 +0100
commit22fe9110612401e879764564ca2078dce0836fff (patch)
tree4d5eed5bb9b64c748dc559f0e86f9550393ea3c9 /gnu/packages/php.scm
parent4d390cad2510797a68f473db347699e748c92e42 (diff)
downloadguix-patches-22fe9110612401e879764564ca2078dce0836fff.tar
guix-patches-22fe9110612401e879764564ca2078dce0836fff.tar.gz
gnu: php: Update to 7.3.1.
* gnu/packages/php.scm (php): Update to 7.3.1.
Diffstat (limited to 'gnu/packages/php.scm')
-rw-r--r--gnu/packages/php.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index 3b925e1740..392ac92430 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -58,7 +58,7 @@
(define-public php
(package
(name "php")
- (version "7.3.0")
+ (version "7.3.1")
(home-page "https://secure.php.net/")
(source (origin
(method url-fetch)
@@ -66,7 +66,7 @@
name "-" version ".tar.xz"))
(sha256
(base32
- "1db0lm84hynilrjj3k1s7skp1y2gl4ip1ihr7662i2xgannmq6bx"))
+ "0qikydmjg8k68l56azq4vg3gkynqwlpzayd5qi9wsl03pr03xsfg"))
(modules '((guix build utils)))
(snippet
'(with-directory-excursion "ext"
@@ -224,6 +224,12 @@
;; This bug should have been fixed in gd 2.2.2.
;; Is it a regression?
"ext/gd/tests/bug65148.phpt"
+ ;; These tests should not be run (disabled because
+ ;; GD_BUNDLED = 0)
+ "ext/gd/tests/bug77198_auto.phpt"
+ "ext/gd/tests/bug77198_threshold.phpt"
+ "ext/gd/tests/bug77200.phpt"
+ "ext/gd/tests/bug77269.phpt"
;; TODO: Enable these when libgd is built with xpm support.
"ext/gd/tests/xpm2gd.phpt"
"ext/gd/tests/xpm2jpg.phpt"
@@ -289,6 +295,10 @@
"ext/mbstring/tests/mb_ereg_variation3.phpt"
"ext/mbstring/tests/mb_ereg_replace_variation1.phpt"
"ext/mbstring/tests/bug72994.phpt"
+ "ext/mbstring/tests/bug77367.phpt"
+ "ext/mbstring/tests/bug77370.phpt"
+ "ext/mbstring/tests/bug77371.phpt"
+ "ext/mbstring/tests/bug77381.phpt"
"ext/ldap/tests/ldap_set_option_error.phpt"
;; Sometimes cannot start the LDAP server.