summaryrefslogtreecommitdiff
path: root/gnu/packages/php.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-11-12 23:56:22 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-11-12 23:57:42 +0100
commit0dd60c1c9bb07bb3488761c95b5f4aab16061602 (patch)
tree355b257de4316548a9013422749fd31166dce99f /gnu/packages/php.scm
parentc6080c3249560ef777b9a4eb6a78e7605b8b98d8 (diff)
downloadguix-patches-0dd60c1c9bb07bb3488761c95b5f4aab16061602.tar
guix-patches-0dd60c1c9bb07bb3488761c95b5f4aab16061602.tar.gz
gnu: php: Update to 7.2.12.
* gnu/packages/php.scm (php): Update to 7.2.12.
Diffstat (limited to 'gnu/packages/php.scm')
-rw-r--r--gnu/packages/php.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index c78902c97c..a22591d377 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -63,7 +63,7 @@
(define-public php
(package
(name "php")
- (version "7.2.10")
+ (version "7.2.12")
(home-page "https://secure.php.net/")
(source (origin
(method url-fetch)
@@ -71,7 +71,7 @@
name "-" version ".tar.xz"))
(sha256
(base32
- "1w0432i5wjga9z8x3rhc72h2ij1jd2aimg5xmhc0hg4f7951bhh1"))
+ "1qbz2j9kzqxxp0mmx02zavvz20ji7izqdnri25g1mrwyhz60974q"))
(modules '((guix build utils)))
(snippet
'(with-directory-excursion "ext"
@@ -186,6 +186,11 @@
(substitute* "ext/standard/tests/streams/bug60602.phpt"
(("'ls'") (string-append "'" (which "ls") "'")))
+ ;; The expected output is slightly different from what is given,
+ ;; in a section that's not related to the actual test
+ (substitute* "sapi/cli/tests/upload_2G.phpt"
+ (("Test\\\\n") "Test\n\n"))
+
;; Drop tests that are known to fail.
(for-each delete-file
'("ext/posix/tests/posix_getgrgid.phpt" ; Requires /etc/group.