summaryrefslogtreecommitdiff
path: root/gnu/packages/photo.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-24 13:48:02 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-24 13:48:02 +0200
commite48c3dd990c57ed694d3c763381801e701ff14ca (patch)
tree6f1ae3e0e78749bda86fef8324d3426347b6818a /gnu/packages/photo.scm
parenta50452508e2dc0c28fcb75fa3c8331b544ded534 (diff)
downloadguix-patches-e48c3dd990c57ed694d3c763381801e701ff14ca.tar
guix-patches-e48c3dd990c57ed694d3c763381801e701ff14ca.tar.gz
gnu: rawtherapee: Update to 5.6.
* gnu/packages/photo.scm (rawtherapee): Update to 5.6. [inputs]: Add librsvg.
Diffstat (limited to 'gnu/packages/photo.scm')
-rw-r--r--gnu/packages/photo.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index e62d13fe91..e7dd0fbbe7 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -499,28 +499,28 @@ a complete panorama and stitch any series of overlapping pictures.")
(define-public rawtherapee
(package
(name "rawtherapee")
- (version "5.5")
+ (version "5.6")
(source (origin
(method url-fetch)
(uri (string-append "http://rawtherapee.com/shared/source/"
"rawtherapee-" version ".tar.xz"))
(sha256
(base32
- "1w28a2rnxnw8hs7s8x8zkccgi5z5y653602jg7g86lfx6zxwjsf1"))))
+ "0x0dcfp6f3j08gr11wq5ah4prp790xy4iadbgsm9kgc0jlalpspr"))))
(build-system cmake-build-system)
(arguments
- '(#:tests? #f ; no test suite
+ '(#:tests? #f ; no test suite
#:build-type "release"
#:configure-flags
(list (string-append "-DLENSFUNDBDIR="
(assoc-ref %build-inputs "lensfun")
"/share/lensfun")
- ; Don't optimize the build for the host machine. See the file
- ; 'ProcessorTargets.cmake' in the source distribution for more
- ; information.
+ ;; Don't optimize the build for the host machine. See the file
+ ;; 'ProcessorTargets.cmake' in the source distribution for more
+ ;; information.
"-DPROC_TARGET_NUMBER=1"
- ; These flags are recommended by upstream for distributed packages.
- ; See the file 'RELEASE_NOTES.txt' in the source distribution.
+ ;; These flags are recommended by upstream for distributed packages.
+ ;; See the file 'RELEASE_NOTES.txt' in the source distribution.
"-O3"
"-DCACHE_NAME_SUFFIX=\"\"")))
(native-inputs
@@ -538,6 +538,7 @@ a complete panorama and stitch any series of overlapping pictures.")
("libiptcdata" ,libiptcdata)
("libjpeg" ,libjpeg)
("libpng" ,libpng)
+ ("librsvg" ,librsvg)
("libsigc++" ,libsigc++)
("libtiff" ,libtiff)
("zlib" ,zlib)))