summaryrefslogtreecommitdiff
path: root/gnu/packages/photo.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-08-12 00:30:27 +0200
committerMarius Bakke <marius@gnu.org>2021-08-12 00:30:27 +0200
commitc4133c43c7cfe2476ebfae87f9e4d10d96de9bc7 (patch)
tree47bd773d2f434384b54e56916c1a287dd8e51511 /gnu/packages/photo.scm
parentffa01e68859bb7a6daa9fcffdc8d77ca35db4bc0 (diff)
parent4eb0a5146ae5a195a29c79f586fcc1e58f7fa69b (diff)
downloadguix-patches-c4133c43c7cfe2476ebfae87f9e4d10d96de9bc7.tar
guix-patches-c4133c43c7cfe2476ebfae87f9e4d10d96de9bc7.tar.gz
Merge branch 'master' into core-updates-frozen
Conflicts: gnu/packages/algebra.scm gnu/packages/games.scm gnu/packages/golang.scm gnu/packages/kerberos.scm gnu/packages/mail.scm gnu/packages/python.scm gnu/packages/ruby.scm gnu/packages/scheme.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/version-control.scm
Diffstat (limited to 'gnu/packages/photo.scm')
-rw-r--r--gnu/packages/photo.scm28
1 files changed, 21 insertions, 7 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 2197623363..8a6abe5991 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -486,6 +486,24 @@ photographic equipment.")
"-DBUILD_TESTING=On")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'libOpenCL-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Statically link to libOpenCL.
+ (substitute* "./src/common/dlopencl.c"
+ (("\"libOpenCL\"")
+ (string-append "\"" (assoc-ref inputs "ocl-icd") "/lib/libOpenCL.so\"")))
+ #t))
+ ;; The use of inline is wrong and darktable cannot compile its kernels
+ ;; with ROCm. See upstream commit
+ ;; https://github.com/darktable-org/darktable/commit/f0d8710f5ef34eb7e33b4064e022ebf3057b9e53
+ (add-after 'unpack 'opencl-inline
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; This is a feature of OpenCL 1.2 and later.
+ (substitute* "data/kernels/CMakeLists.txt"
+ (("CL1\\.1") "CL1.2"))
+ (substitute* (find-files "data/kernels" "\\.(cl|h)$")
+ (("inline") "static inline"))
+ #t))
(add-before 'configure 'prepare-build-environment
(lambda* (#:key inputs #:allow-other-keys)
;; Rawspeed fails to build with GCC due to OpenMP error:
@@ -516,11 +534,7 @@ photographic equipment.")
;; For GtkFileChooserDialog.
`("GSETTINGS_SCHEMA_DIR" =
(,(string-append (assoc-ref inputs "gtk+")
- "/share/glib-2.0/schemas")))
- ;; For libOpenCL.so.
- `("LD_LIBRARY_PATH" =
- (,(string-append (assoc-ref inputs "ocl-icd")
- "/lib"))))
+ "/share/glib-2.0/schemas"))))
#t)))))
(native-inputs
`(("clang" ,clang-11)
@@ -769,7 +783,7 @@ a complete panorama and stitch any series of overlapping pictures.")
(version "5.8")
(source (origin
(method url-fetch)
- (uri (string-append "http://rawtherapee.com/shared/source/"
+ (uri (string-append "https://rawtherapee.com/shared/source/"
"rawtherapee-" version ".tar.xz"))
(sha256
(base32
@@ -809,7 +823,7 @@ a complete panorama and stitch any series of overlapping pictures.")
("libsigc++" ,libsigc++)
("libtiff" ,libtiff)
("zlib" ,zlib)))
- (home-page "http://rawtherapee.com")
+ (home-page "https://rawtherapee.com")
(synopsis "Raw image developing and processing")
(description "RawTherapee is a raw image processing suite. It comprises a
subset of image editing operations specifically aimed at non-destructive raw