summaryrefslogtreecommitdiff
path: root/gnu/packages/photo.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-12 16:50:47 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-12 17:46:23 +0000
commita1eca979fb8da842e73c42f4f53be29b169810f2 (patch)
tree681c7283e412bb8a29c2531c4408b49c3e184764 /gnu/packages/photo.scm
parent48d86a9ec6d8d2e97da2299ea41a03ef4cdaab83 (diff)
parent371aa5777a3805a3886f3feea5f1960fe3fe4219 (diff)
downloadguix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar
guix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen.
Diffstat (limited to 'gnu/packages/photo.scm')
-rw-r--r--gnu/packages/photo.scm26
1 files changed, 6 insertions, 20 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 8634f00158..e85af9305a 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -471,7 +471,7 @@ photographic equipment.")
(define-public darktable
(package
(name "darktable")
- (version "3.6.0")
+ (version "3.6.1")
(source
(origin
(method url-fetch)
@@ -479,7 +479,7 @@ photographic equipment.")
"https://github.com/darktable-org/darktable/releases/"
"download/release-" version "/darktable-" version ".tar.xz"))
(sha256
- (base32 "0f8aqwkgw4gs97b5i4ygiqk5zilwq7ax7zwdd31r72zk98cd1g46"))))
+ (base32 "051dwhdqa9q3zyrvr78g0cfzl1zhaagfvgx9axa9895q0g0wggx2"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags '("-DBINARY_PACKAGE_BUILD=On"
@@ -492,19 +492,7 @@ photographic equipment.")
(substitute* "./src/common/dlopencl.c"
(("\"libOpenCL\"")
(string-append "\"" (assoc-ref inputs "opencl-icd-loader")
- "/lib/libOpenCL.so\"")))
- #t))
- ;; The use of inline is wrong and darktable cannot compile its kernels
- ;; with ROCm. See upstream commit
- ;; https://github.com/darktable-org/darktable/commit/f0d8710f5ef34eb7e33b4064e022ebf3057b9e53
- (add-after 'unpack 'opencl-inline
- (lambda* (#:key inputs #:allow-other-keys)
- ;; This is a feature of OpenCL 1.2 and later.
- (substitute* "data/kernels/CMakeLists.txt"
- (("CL1\\.1") "CL1.2"))
- (substitute* (find-files "data/kernels" "\\.(cl|h)$")
- (("inline") "static inline"))
- #t))
+ "/lib/libOpenCL.so\"")))))
(add-before 'configure 'prepare-build-environment
(lambda* (#:key inputs #:allow-other-keys)
;; Rawspeed fails to build with GCC due to OpenMP error:
@@ -514,8 +502,7 @@ photographic equipment.")
;; it to the Clang dir. We fix this by patching CMakeLists.txt.
(substitute* "CMakeLists.txt"
(("\\$\\{LLVM_INSTALL_PREFIX\\}")
- (assoc-ref %build-inputs "clang")))
- #t))
+ (assoc-ref %build-inputs "clang")))))
(add-before 'configure 'set-LDFLAGS-and-CPATH
(lambda* (#:key inputs outputs #:allow-other-keys)
(setenv "LDFLAGS"
@@ -535,8 +522,7 @@ photographic equipment.")
;; For GtkFileChooserDialog.
`("GSETTINGS_SCHEMA_DIR" =
(,(string-append (assoc-ref inputs "gtk+")
- "/share/glib-2.0/schemas"))))
- #t)))))
+ "/share/glib-2.0/schemas")))))))))
(native-inputs
`(("clang" ,clang-11)
("cmocka" ,cmocka)
@@ -595,7 +581,7 @@ developer. It manages your digital negatives in a database, lets you view
them through a zoomable lighttable and enables you to develop raw images
and enhance them.")
;; See src/is_supported_platform.h for supported platforms.
- (supported-systems '("x86_64-linux" "aarch64-linux"))
+ (supported-systems '("x86_64-linux" "aarch64-linux" "powerpc64le-linux"))
(license (list license:gpl3+ ;; Darktable itself.
license:lgpl2.1+)))) ;; Rawspeed library.