summaryrefslogtreecommitdiff
path: root/gnu/packages/photo.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-12-12 01:24:32 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-18 22:36:37 +0100
commit17ac8bb67038608547801aa2563b04526fee9932 (patch)
tree34cdb7455c03015457a1a8439d5c29ee44894b1c /gnu/packages/photo.scm
parent8e53fe2b91d2776bc1529e7b34967c8f1d9edc32 (diff)
downloadguix-patches-17ac8bb67038608547801aa2563b04526fee9932.tar
guix-patches-17ac8bb67038608547801aa2563b04526fee9932.tar.gz
gnu: darktable: Fix build failure.
* gnu/packages/photo.scm (darktable)[arguments]: Move CPATH override from #:make-flags to a phase, so the GETENV call returns useful data.
Diffstat (limited to 'gnu/packages/photo.scm')
-rw-r--r--gnu/packages/photo.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index f6d86f0857..20af5cc7f5 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -374,18 +374,19 @@ photographic equipment.")
(arguments
`(#:tests? #f ; there are no tests
#:configure-flags '("-DBINARY_PACKAGE_BUILD=On")
- #:make-flags
- (list
- (string-append "CPATH=" (assoc-ref %build-inputs "ilmbase")
- "/include/OpenEXR:" (or (getenv "CPATH") "")))
#:phases
(modify-phases %standard-phases
- (add-before 'configure 'set-ldflags
- (lambda* (#:key outputs #:allow-other-keys)
+ (add-before 'configure 'set-LDFLAGS-and-CPATH
+ (lambda* (#:key inputs outputs #:allow-other-keys)
(setenv "LDFLAGS"
(string-append
"-Wl,-rpath="
(assoc-ref outputs "out") "/lib/darktable"))
+
+ ;; Ensure the OpenEXR headers are found.
+ (setenv "CPATH"
+ (string-append (assoc-ref inputs "ilmbase")
+ "/include/OpenEXR:" (or (getenv "CPATH") "")))
#t)))))
(native-inputs
`(("llvm" ,llvm-3.9.1)