summaryrefslogtreecommitdiff
path: root/gnu/packages/perl6.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-03-10 22:23:50 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-03-23 22:26:52 +0200
commitf0f3f70b286d634ed53b2f21f5e5633488efd4e0 (patch)
tree3c75abe4daac6d7827d08d35594c3eb9ee238341 /gnu/packages/perl6.scm
parentcdecb8d72dfd55d0179ed80706d6f2bb40e4d4d1 (diff)
downloadguix-patches-f0f3f70b286d634ed53b2f21f5e5633488efd4e0.tar
guix-patches-f0f3f70b286d634ed53b2f21f5e5633488efd4e0.tar.gz
gnu: Add perl6-json.
* gnu/packages/perl6.scm (perl6-json): New variable.
Diffstat (limited to 'gnu/packages/perl6.scm')
-rw-r--r--gnu/packages/perl6.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index f67533854f..f227786e8d 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -284,6 +284,29 @@ code. Any grammar in the lexical scope of the use statement will automatically
have profiling information collected when the grammar is used.")
(license license:artistic2.0))))
+(define-public perl6-json
+ (package
+ (name "perl6-json")
+ (version "1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/moritz/json")
+ ;; The commit where 1.0 was "tagged"
+ (commit "a5ef8c179350dae44ce7fb1abb684fc62c1c2b99")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1kzryxkqyr129rcckd4jh0dfxdgzv71qx8dpkpm1divbfjyknlay"))))
+ (build-system rakudo-build-system)
+ (arguments '(#:with-zef? #f))
+ (home-page "https://github.com/moritz/json")
+ (synopsis "A minimal JSON (de)serializer")
+ (description "This module is a simple Perl 6 module for serializing and
+deserializing JSON.")
+ (license license:artistic2.0)))
+
(define-public perl6-json-class
(package
(name "perl6-json-class")