summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-01 23:37:20 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-01 23:37:55 -0500
commitd38e410c6a4b101b544774620ca7158ae5c57f7c (patch)
tree400d8997a28baf30742422aa14e2182a9c30d5e8 /gnu/packages/perl.scm
parenta8384752c38acfe8c1e13ea23ca54f95097dfcbc (diff)
downloadguix-patches-d38e410c6a4b101b544774620ca7158ae5c57f7c.tar
guix-patches-d38e410c6a4b101b544774620ca7158ae5c57f7c.tar.gz
gnu: Add perl-eval-withlexicals.
* gnu/packages/perl.scm (perl-eval-withlexicals): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 040206504d..896a474bba 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -28,6 +28,7 @@
;;; Copyright © 2020 Paul Garlick <pgarlick@tourbillion-technology.com>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
+;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4056,6 +4057,41 @@ environment, other than a fixed list of specified variables. Compilation
errors are rethrown automatically.")
(license (package-license perl))))
+(define-public perl-eval-withlexicals
+ (package
+ (name "perl-eval-withlexicals")
+ (version "1.003006")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/H/HA/HAARG/Eval-WithLexicals-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0x09mq0q745cxkw3xgr0h7dil7p1pdq3l5299kj3mk2ijkk2gwb6"))))
+ (build-system perl-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'install 'wrap-tinyrepl
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out "/bin/tinyrepl")
+ `("PERL5LIB" ":" prefix
+ (,(getenv "PERL5LIB")
+ ,(string-append out "/lib/perl5/site_perl"))))
+ #t))))))
+ (propagated-inputs
+ `(("perl-moo" ,perl-moo)
+ ("perl-strictures" ,perl-strictures)))
+ (home-page "https://metacpan.org/release/Eval-WithLexicals")
+ (synopsis "Lexical scope evaluation library for Perl")
+ (description "The Eval::WithLexicals Perl library provides support for
+lexical scope evaluation. This package also includes the @command{tinyrepl}
+command, which can be used as a minimal Perl read-eval-print loop (REPL).")
+ (license (package-license perl))))
+
(define-public perl-exception-class
(package
(name "perl-exception-class")