summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-12-28 16:12:58 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-14 09:24:50 -0500
commitb4b6f676cd35c2e45934e9f5a6346ce6265e1c40 (patch)
tree7864d2b91870f446eae88968a2486fbdb1424ee3 /gnu/packages/perl.scm
parent81920e6d59de6d58afddb11d7acef357533f8440 (diff)
downloadguix-patches-b4b6f676cd35c2e45934e9f5a6346ce6265e1c40.tar
guix-patches-b4b6f676cd35c2e45934e9f5a6346ce6265e1c40.tar.gz
gnu: Add perl-sgmls.
* gnu/packages/perl.scm (perl-sgmls): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 896a474bba..da05f7a95b 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -11141,6 +11141,39 @@ package takes some liberties with the SDL API, and attempts to adhere to the
spirit of both the SDL and Perl.")
(license license:lgpl2.1)))
+(define-public perl-sgmls
+ (package
+ (name "perl-sgmls")
+ (version "1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/R/RA/RAAB/SGMLSpm-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1gdjf3mcz2bxir0l9iljxiz6qqqg3a9gg23y5wjg538w552r432m"))))
+ (build-system perl-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'install 'wrap-script
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (site (string-append out "/lib/perl5/site_perl")))
+ (with-directory-excursion out
+ (rename-file "bin/sgmlspl.pl" "bin/sgmlspl")
+ (wrap-program "bin/sgmlspl"
+ `("PERL5LIB" suffix (,site))))
+ #t))))))
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)))
+ (home-page "https://metacpan.org/release/RAAB/SGMLSpm-1.1")
+ (synopsis "Perl module for processing SGML parser output")
+ (description "This package contains @code{SGMLS.pm}, a perl5 class library
+for parsing the output from an SGML parser such as OpenSP. It also includes
+the @command{sgmlspl} command, an Perl script showcasing how the library can
+be used.")
+ (license license:gpl2+)))
+
(define-public perl-shell-command
(package
(name "perl-shell-command")