summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-23 11:22:30 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-23 11:29:38 +0100
commitb15e543d303ea58fdc0f0541c708389f9d513e3d (patch)
tree5c4bd48d67d4d3cd4806269dcabf58382f448bed /gnu/packages/perl.scm
parent4efc08d895274ee39e6e6e5c49121fb05a0281b6 (diff)
parentdaf7b5ecef8de0e536ffd8d2957f022d010767a8 (diff)
downloadguix-patches-b15e543d303ea58fdc0f0541c708389f9d513e3d.tar
guix-patches-b15e543d303ea58fdc0f0541c708389f9d513e3d.tar.gz
Merge branch 'master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 16 insertions, 5 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 4295233c04..933ec5928a 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -845,7 +845,7 @@ Agency.")
("perl-mojolicious" ,perl-mojolicious)))
(home-page "https://metacpan.org/release/Business-ISBN")
(synopsis "Work with International Standard Book Numbers")
- (description "This modules provides tools to deal with International
+ (description "This module provides tools to deal with International
Standard Book Numbers, including ISBN-10 and ISBN-13.")
(license license:artistic2.0)))
@@ -864,7 +864,7 @@ Standard Book Numbers, including ISBN-10 and ISBN-13.")
(build-system perl-build-system)
(home-page "https://metacpan.org/release/Business-ISSN")
(synopsis "Work with International Standard Serial Numbers")
- (description "This modules provides tools to deal with International
+ (description "This module provides tools to deal with International
Standard Serial Numbers.")
(license (package-license perl))))
@@ -884,7 +884,7 @@ Standard Serial Numbers.")
`(("perl-tie-cycle" ,perl-tie-cycle)))
(home-page "https://metacpan.org/release/Business-ISMN")
(synopsis "Work with International Standard Music Numbers")
- (description "This modules provides tools to deal with International
+ (description "This module provides tools to deal with International
Standard Music Numbers.")
(license (package-license perl))))
@@ -5403,6 +5403,17 @@ for immediate access from Perl.")
(base32
"1b3sr39813di3j1kwbgn1xq2z726rhjjdw809ydzgmshj26jb1gi"))))
(build-system perl-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((make (assoc-ref inputs "make")))
+ (substitute* "lib/Inline/C.pm"
+ (("'\"make\"'")
+ (string-append "'\"" make "/bin/make\"'"))
+ (("'\"make install\"'")
+ (string-append "'\"" make "/bin/make install\"'")))))))))
(native-inputs
`(("perl-file-copy-recursive" ,perl-file-copy-recursive)
("perl-file-sharedir-install" ,perl-file-sharedir-install)
@@ -5920,7 +5931,7 @@ logging mechanism.")
throughout programs and projects. Every message will be logged with
stacktraces, timestamps and so on. You can use built-in handlers
immediately, or after the fact when you inspect the error stack. It
-is highly configurable and let's you even provide your own handlers
+is highly configurable and lets you even provide your own handlers
for dealing with messages.")
(license (package-license perl))))
@@ -10663,7 +10674,7 @@ operations can also be performed on the IxHash.")
(home-page "https://metacpan.org/release/Tie-Handle-Offset")
(synopsis "Special file handle that hides the beginning of a file")
(description
- "This modules provides a file handle that hides the beginning of a file,
+ "This module provides a file handle that hides the beginning of a file,
by modifying the @code{seek()} and @code{tell()} calls.")
(license license:asl2.0)))