summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-04-08 16:13:45 -0500
committerEric Bavier <bavier@member.fsf.org>2015-04-19 19:48:52 -0500
commit8ac84f230c85bcd8803bb994c801c1076bbfc7e3 (patch)
treed7e38a5a10705eb515eb9fa0fceff43eba3f1ddc /gnu/packages/perl.scm
parent10ef803e7ddc742fcb39076eb8a60bacbf4c3d6a (diff)
downloadguix-patches-8ac84f230c85bcd8803bb994c801c1076bbfc7e3.tar
guix-patches-8ac84f230c85bcd8803bb994c801c1076bbfc7e3.tar.gz
gnu: Add Sys-Hostname-Long.
* gnu/packages/perl.scm (perl-sys-hostname-long): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 2c2cead112..26c193fe4e 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -4319,6 +4319,26 @@ clock speed.")
"Sys-CPU-" version))
(license (package-license perl))))
+(define-public perl-sys-hostname-long
+ (package
+ (name "perl-sys-hostname-long")
+ (version "1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/S/SC/SCOTT/"
+ "Sys-Hostname-Long-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1jv5n8jv48c1p8svjsigyxndv1ygsq8wgwj9c7ypx1vaf3rns679"))))
+ (build-system perl-build-system)
+ (arguments `(#:tests? #f)) ;no `hostname' during build
+ (home-page "http://search.cpan.org/dist/Sys-Hostname-Long")
+ (synopsis "Get full hostname in Perl")
+ (description "Sys::Hostname::Long tries very hard to get the full hostname
+of a system.")
+ (license (package-license perl))))
+
(define-public perl-task-weaken
(package
(name "perl-task-weaken")