summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-05-01 14:05:00 +0200
committerLudovic Courtès <ludo@gnu.org>2021-05-03 18:26:50 +0200
commit66f309a5534e7cacfcbfb2638fd38c0defb60faa (patch)
treec376d04fa998de6f6b0c5576d831edbe91564241 /gnu/packages/perl.scm
parent319e0e0aebee7e8ec2f355718003378f34bae064 (diff)
downloadguix-patches-66f309a5534e7cacfcbfb2638fd38c0defb60faa.tar
guix-patches-66f309a5534e7cacfcbfb2638fd38c0defb60faa.tar.gz
gnu: Add perl-linux-inotify2.
* gnu/packages/perl.scm (perl-linux-inotify2): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 11201ce4bc..1efaef9293 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -29,6 +29,7 @@
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5904,6 +5905,28 @@ writing system to another, based on national or international transliteration
tables. Where possible a reverse transliteration is supported.")
(license (package-license perl))))
+(define-public perl-linux-inotify2
+ (package
+ (name "perl-linux-inotify2")
+ (version "2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/M/ML/MLEHMANN/Linux-Inotify2-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0crlxmaa4lsgdjm5p9ib8rdxiy70qj1s68za3q3v57v8ll6s4hfx"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-common-sense" ,perl-common-sense)))
+ (home-page "https://metacpan.org/release/Linux-Inotify2")
+ (synopsis "Scalable file change notification")
+ (description "This module implements an interface to the Linux 2.6.13 and
+later Inotify file change notification system.")
+ (license (package-license perl))))
+
(define-public perl-list-allutils
(package
(name "perl-list-allutils")