summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-14 11:07:39 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-14 12:19:42 +0200
commit25985c69577ce1ec33ffa75c25bd1d71170bc2fa (patch)
tree8387507b12aea5bba7a8038790470b92674d1063 /gnu/packages/perl.scm
parent8331e2357b67e1b6b2f43ccaf904d7752e124645 (diff)
downloadguix-patches-25985c69577ce1ec33ffa75c25bd1d71170bc2fa.tar
guix-patches-25985c69577ce1ec33ffa75c25bd1d71170bc2fa.tar.gz
gnu: Add perl-hook-lexwrap.
* gnu/packages/perl.scm (perl-hook-lexwrap): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index e7d4ce8392..60a2008636 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -26,6 +26,7 @@
;;; Copyright © 2019 Stephen J. Scheck <sscheck@cpan.org>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Paul Garlick <pgarlick@tourbillion-technology.com>
+;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4980,6 +4981,29 @@ merged.")
that may contain multiple values per key, inspired by MultiDict of WebOb.")
(license (package-license perl))))
+(define-public perl-hook-lexwrap
+ (package
+ (name "perl-hook-lexwrap")
+ (version "0.26")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/E/ET/ETHER/"
+ "Hook-LexWrap-" version ".tar.gz"))
+ (sha256
+ (base32 "0bgc6w8zs45n6ksgk0zisn9a2vcr3lmzipkan2a94kzrk1gxq2xn"))))
+ (build-system perl-build-system)
+ (home-page
+ "https://metacpan.org/release/Hook-LexWrap")
+ (synopsis "Lexically scoped subroutine wrappers")
+ (description
+ "Hook::LexWrap allows you to install a pre- or post-wrapper (or
+both) around an existing subroutine. Unlike other modules that
+provide this capacity (e.g., Hook::PreAndPost and Hook::WrapSub),
+Hook::LexWrap implements wrappers in such a way that the standard
+caller function works correctly within the wrapped subroutine.")
+ (license perl-license)))
+
(define-public perl-importer
(package
(name "perl-importer")