summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2019-11-03 13:28:34 +0100
committerAndreas Enge <andreas@enge.fr>2019-11-05 22:08:38 +0100
commit1f03143c5380b21f1883c8acbbe8e76e28a086fa (patch)
tree6161343338e6345ca3902ffcc157d1787912cdd8 /gnu/packages/perl.scm
parentc07bc1d2ca1029b89c807cc6e62e4c099aebedbd (diff)
downloadguix-patches-1f03143c5380b21f1883c8acbbe8e76e28a086fa.tar
guix-patches-1f03143c5380b21f1883c8acbbe8e76e28a086fa.tar.gz
gnu: Add perl-extutils-cppguess.
* gnu/packages/perl.scm (perl-extutils-cppguess): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index f92d50290e..0b17db1913 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2019 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015, 2016, 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017, 2019 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
@@ -3320,6 +3320,33 @@ By itself it is not a particularly interesting module by any measure, however
it ties together a family of modern toolchain modules.")
(license (package-license perl))))
+(define-public perl-extutils-cppguess
+ (package
+ (name "perl-extutils-cppguess")
+ (version "0.20")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/E/ET/ETJ/ExtUtils-CppGuess-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0q9ynigk600fv95xac6aslrg2k19m6qbzf5hqfsnall8113r3gqj"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-capture-tiny" ,perl-capture-tiny)
+ ("perl-module-build" ,perl-module-build)))
+ (propagated-inputs
+ `(("perl-capture-tiny" ,perl-capture-tiny)))
+ (home-page
+ "https://metacpan.org/release/ExtUtils-CppGuess")
+ (synopsis "Tool for guessing C++ compiler and flags")
+ (description "ExtUtils::CppGuess attempts to guess the C++ compiler that
+is compatible with the C compiler used to build perl.")
+ (license (package-license perl))))
+
(define-public perl-extutils-depends
(package
(name "perl-extutils-depends")