summaryrefslogtreecommitdiff
path: root/gnu/packages/perl-web.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-03-22 05:20:42 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-03-26 22:47:16 +0300
commite0de023eae9f98cb809a4866a84d85efaa262e56 (patch)
tree04569ac12a5ce7a192014b7fb7aa55b0e439a068 /gnu/packages/perl-web.scm
parent786d3de297c75f70193ceda92af8faf697f3784d (diff)
downloadguix-patches-e0de023eae9f98cb809a4866a84d85efaa262e56.tar
guix-patches-e0de023eae9f98cb809a4866a84d85efaa262e56.tar.gz
gnu: Add perl-uri-escape.
* gnu/packages/perl-web.scm (perl-uri-escape): New public variable.
Diffstat (limited to 'gnu/packages/perl-web.scm')
-rw-r--r--gnu/packages/perl-web.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl-web.scm b/gnu/packages/perl-web.scm
index 0500cee0dc..7a398675b2 100644
--- a/gnu/packages/perl-web.scm
+++ b/gnu/packages/perl-web.scm
@@ -21,6 +21,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
#:use-module (guix packages)
+ #:use-module (gnu packages perl-check)
#:use-module (guix download)
#:use-module (guix build-system perl))
@@ -46,3 +47,26 @@ keep you going, learning by doing was much fun. While most of the techniques
used are outdated now, the idea behind it is not. Mojolicious is a new
endeavor to implement this idea using modern technologies.")
(license license:artistic2.0)))
+
+(define-public perl-uri-escape
+ (package
+ (name "perl-uri-escape")
+ (version "1.73")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/E/ET/ETHER/URI-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "04z4xwiryrbxxi48bwbkgq9q9pwfgqry3wp0ramcrwv3dx5ap9yc"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-needs" ,perl-test-needs)))
+ (home-page "https://github.com/libwww-perl/URI")
+ (synopsis "Percent-encode and percent-decode unsafe characters")
+ (description "This module provides functions to percent-encode and
+percent-decode URI strings as defined by RFC 3986. Percent-encoding URI's is
+informally called URI escaping. This is the terminology used by this module,
+which predates the formalization of the terms by the RFC by several years.")
+ (license license:perl-license)))