summaryrefslogtreecommitdiff
path: root/gnu/packages/perl-check.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-11 15:05:30 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-11 17:22:31 +0200
commitab45b38feada5bf4721c8f1018b9cc9d7250069e (patch)
tree45950cf7f1b938dfbee31ed0fa42dc2246345e0e /gnu/packages/perl-check.scm
parent2db5f9b68a29d38a4447c2959df694c266647d9b (diff)
downloadguix-patches-ab45b38feada5bf4721c8f1018b9cc9d7250069e.tar
guix-patches-ab45b38feada5bf4721c8f1018b9cc9d7250069e.tar.gz
gnu: Use static & unversioned CPAN home pages.
Constructing home pages to be version-specific is not something we really want or do elsewhere, and interferers with mass updates like the one I'm about to make. * gnu/packages/glib.scm (perl-net-dbus-glib)[home-page]: Use canonical home page. * gnu/packages/perl-check.scm (perl-test-nowarnings, perl-test-output) (perl-test-simple, perl-test-tester)[home-page]: Likewise. * gnu/packages/perl.scm (perl-benchmark-timer, perl-clone) (perl-digest-sha1, perl-file-which, perl-getopt-tabular, perl-io-string) (perl-ipc-run3, perl-probe-perl, perl-regexp-common, perl-sys-cpu) [home-page]: Likewise. * gnu/packages/tcl.scm (perl-tk)[home-page]: Likewise. * gnu/packages/tls.scm (perl-net-ssleay)[home-page]: Likewise. * gnu/packages/web.scm (perl-www-curl)[home-page]: Likewise. * gnu/packages/xml.scm (perl-xml-dom)[home-page]: Likewise. * gnu/packages/xorg.scm (perl-x11-protocol-other)[home-page]: Likewise.
Diffstat (limited to 'gnu/packages/perl-check.scm')
-rw-r--r--gnu/packages/perl-check.scm13
1 files changed, 4 insertions, 9 deletions
diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index 89a761f0a7..b753cdcf7e 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -864,8 +864,7 @@ stored. It automatically adds an extra test that will run when your script
ends to check that there were no warnings. If there were any warnings, the
test will fail and output diagnostics of where, when and what the warning was,
including a stack trace of what was going on when it occurred.")
- (home-page (string-append "http://search.cpan.org/~adamk//"
- "Test-NoWarnings-" version))
+ (home-page "http://search.cpan.org/~adamk/Test-NoWarnings")
(license lgpl2.1)))
(define-public perl-test-number-delta
@@ -912,8 +911,7 @@ usually called epsilon. This module provides such a function for use with
"Test::Output provides a simple interface for testing output sent to
STDOUT or STDERR. A number of different utilities are included to try and be
as flexible as possible to the tester.")
- (home-page (string-append "http://search.cpan.org/~bdfoy//"
- "Test-Output-" version))
+ (home-page "http://search.cpan.org/~bdfoy/Test-Output")
(license perl-license)))
(define-public perl-test-pod
@@ -1114,8 +1112,7 @@ makes fork(2) safe to use in test cases.")
(synopsis "Basic utilities for writing tests")
(description
"Test::Simple contains basic utilities for writing tests.")
- (home-page (string-append "http://search.cpan.org/~exodist//"
- "Test-Simple-" version))
+ (home-page "http://search.cpan.org/~exodist/Test-Simple")
(license perl-license)))
(define-public perl-test-taint
@@ -1160,9 +1157,7 @@ easy ways to check and report on the taintedness of your data, in standard
(description
"Test::Tester allows testing of test modules based on Test::Builder with
a minimum of effort.")
- (home-page (string-append "http://search.cpan.org/~fdaly//"
- "Test-Tester-" version))
- ;; "Under the same license as Perl itself"
+ (home-page "http://search.cpan.org/~fdaly/Test-Tester")
(license perl-license)))
(define-public perl-test-perltidy