summaryrefslogtreecommitdiff
path: root/gnu/packages/perl-check.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2018-06-15 20:19:10 -0400
committerKei Kebreau <kkebreau@posteo.net>2018-06-16 20:41:16 -0400
commit52b1551bff9befe12c13bfe7c9f2d0fa5810b455 (patch)
treec11e73e080bdb0df8d30c2d885f9c37488fceb5c /gnu/packages/perl-check.scm
parent048657cccdac3042f994253153aa3c1d6ebc0130 (diff)
downloadguix-patches-52b1551bff9befe12c13bfe7c9f2d0fa5810b455.tar
guix-patches-52b1551bff9befe12c13bfe7c9f2d0fa5810b455.tar.gz
gnu: Add perl-test-distmanifest.
* gnu/packages/perl-check.scm (perl-test-distmanifest): New variable.
Diffstat (limited to 'gnu/packages/perl-check.scm')
-rw-r--r--gnu/packages/perl-check.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index a1be996e04..4cac6dcd9e 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018 Pierre Neidhardt <ambrevar@gmail.com>
+;;; Copyright © 2018 Kei Kebreau <kkebreau@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -364,6 +365,30 @@ modified or tested with this API, making it simple to test both individual
files, as well as to verify that there are no missing or unknown files.")
(license perl-license)))
+(define-public perl-test-distmanifest
+ (package
+ (name "perl-test-distmanifest")
+ (version "1.014")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/E/ET/ETHER/Test-DistManifest-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1ifpff5simjslabwy7ac6kdylv4c0b5b39fgpwf9ha16yh6w49ix"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)))
+ (propagated-inputs
+ `(("perl-module-manifest" ,perl-module-manifest)))
+ (home-page "https://github.com/jawnsy/Test-DistManifest")
+ (synopsis "Author test that validates a package @file{MANIFEST}")
+ (description
+ "@code{Test::DistManifest} provides a simple method of testing that a
+@file{MANIFEST} file matches its distribution.")
+ (license perl-license)))
+
(define-public perl-test-eol
(package
(name "perl-test-eol")