summaryrefslogtreecommitdiff
path: root/gnu/packages/perl-check.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-03-24 18:10:29 +0000
committerChristopher Baines <mail@cbaines.net>2019-04-14 10:45:58 +0100
commit402cfebf5ce8dbc87d912347436e56af83c88543 (patch)
tree0110b44a7b967d182574a378923ae12e6d666234 /gnu/packages/perl-check.scm
parent9c5551c4cce836cdc00b3d8bc01c0600f37d710e (diff)
downloadguix-patches-402cfebf5ce8dbc87d912347436e56af83c88543.tar
guix-patches-402cfebf5ce8dbc87d912347436e56af83c88543.tar.gz
gnu: Add perl-test-file.
* gnu/packages/perl-check.scm (perl-test-file): New variable.
Diffstat (limited to 'gnu/packages/perl-check.scm')
-rw-r--r--gnu/packages/perl-check.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index fc39ae37a7..2399b073cd 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -548,6 +548,30 @@ Test::Exception. It does much less, but should allow greater flexibility in
testing exception-throwing code with about the same amount of typing.")
(license perl-license)))
+(define-public perl-test-file
+ (package
+ (name "perl-test-file")
+ (version "1.443")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/B/BD/BDFOY/Test-File-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1mdwb3x8d4l24wsymamsnq2c73a637v4q5kmb5xqqz31iymsdd31"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-utf8" ,perl-test-utf8)))
+ (home-page "https://metacpan.org/release/Test-File")
+ (synopsis "Utilities for testing file attributes")
+ (description
+ "@code{Test::File} provides a collection of test utilities for file
+attributes.")
+ (license perl-license)))
+
(define-public perl-test-file-sharedir-dist
(package
(name "perl-test-file-sharedir-dist")