summaryrefslogtreecommitdiff
path: root/gnu/packages/perl-check.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-07-18 16:05:21 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-18 19:50:01 +0200
commit0e47fcced442d8e7c1b05184fdc1c14f10ed04ec (patch)
tree4ae844bc0ec3c670f8697bdc24362c122fa718ad /gnu/packages/perl-check.scm
parente4b70bc55a538569465bcedee19d1f2607308e65 (diff)
parent8b1bde7bb3936a64244824500ffe60f123704437 (diff)
downloadguix-patches-0e47fcced442d8e7c1b05184fdc1c14f10ed04ec.tar
guix-patches-0e47fcced442d8e7c1b05184fdc1c14f10ed04ec.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/perl-check.scm')
-rw-r--r--gnu/packages/perl-check.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index c64b985c4c..0bcefb165f 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -1157,6 +1157,31 @@ Pod::Simple to do the heavy lifting.")
checks for pod coverage of all appropriate files.")
(license artistic2.0)))
+(define-public perl-test-portability-files
+ (package
+ (name "perl-test-portability-files")
+ (version "0.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/A/AB/ABRAXXA/"
+ "Test-Portability-Files-" version ".tar.gz"))
+ (sha256
+ (base32 "05hs80gljkd6mhb8zvilyk3pjqxp5samgnymam5v9h9d94rb9r08"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-simple" ,perl-test-simple)))
+ (propagated-inputs
+ `(("perl-pathtools" ,perl-pathtools)))
+ (home-page "https://metacpan.org/dist/Test-Portability-Files")
+ (synopsis "Check file names portability")
+ (description "Test::Portability::Files module is used to check the
+portability across operating systems of the names of the files present in the
+distribution of a module. The tests use the advices given in 'Files and
+Filesystems' in perlport. The author of a distribution can select which tests
+to execute.")
+ (license perl-license)))
+
(define-public perl-test-requires
(package
(name "perl-test-requires")