summaryrefslogtreecommitdiff
path: root/gnu/packages/pep.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-05-04 21:03:37 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-05-31 10:45:53 +0200
commitc7f023723c1de3f82a3abfa47b8366fccbd3540a (patch)
tree0217b964f6f23fc1e9f6ca5ce7e0b5f5b8ce38bd /gnu/packages/pep.scm
parent47f31c0afec855e3158beb7467f9f20dcae02031 (diff)
downloadguix-patches-c7f023723c1de3f82a3abfa47b8366fccbd3540a.tar
guix-patches-c7f023723c1de3f82a3abfa47b8366fccbd3540a.tar.gz
gnu: yml2: Update to 2.7.0.
* gnu/packages/pep.scm (yml2): Update to 2.7.0. [source]: Switch to new git repo.
Diffstat (limited to 'gnu/packages/pep.scm')
-rw-r--r--gnu/packages/pep.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/pep.scm b/gnu/packages/pep.scm
index 289796a377..6d24534f7e 100644
--- a/gnu/packages/pep.scm
+++ b/gnu/packages/pep.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2016, 2020, 2021 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -40,15 +40,16 @@
(define-public yml2
(package
(name "yml2")
- (version "2.6.3")
- (source (origin
- (method hg-fetch)
- (uri (hg-reference
- (url "https://pep.foundation/dev/repos/yml2")
- (changeset version)))
- (file-name (string-append name "-" version "-checkout"))
+ (version "2.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitea.pep.foundation/fdik/yml2")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "10jjjyq1mz18zkzvxd62aba00h69gd9cglisqcvb81j67ml2v1bx"))))
+ (base32 "0fm1x1fv4lwcpbn59s55idzf7x173n59xpz8rlrxalmi6gvsjijr"))))
(build-system python-build-system)
(propagated-inputs
`(("python-lxml" ,python-lxml)))