summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-09 21:53:32 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-06-14 00:24:42 -0400
commitea0a51071e68c37a4c9c25421cf03bc2f442c67b (patch)
treec30587b862169414a2170b86aae6ba4dbc5a2796 /gnu/packages/pdf.scm
parent0b5120fb03db5226871b3482a72b1e6fdaa59ead (diff)
downloadguix-patches-ea0a51071e68c37a4c9c25421cf03bc2f442c67b.tar
guix-patches-ea0a51071e68c37a4c9c25421cf03bc2f442c67b.tar.gz
gnu: Rename qtbase to qtbase-5.
This change was automated via the following command: $ git ls-files | xargs sed -i 's/,qtbase)/,qtbase-5)/g' $ git ls-files | xargs sed -i 's/inherit qtbase)/inherit qtbase-5)/g' $ git ls-files | xargs sed -i 's/package-version qtbase)/package-version qtbase-5)/g' $ git checkout etc # to clear some spurious changes This is done so the qtbase package can be upgraded to version 6 in the following commit.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 8f163bdd37..9298332940 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -177,7 +177,7 @@ information.")
`(("python-pypdf2" ,python-pypdf2)
("python-pyqt" ,python-pyqt)
("python-poppler-qt5" ,python-poppler-qt5)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(home-page "http://crazy-compilers.com/flyer-composer")
(synopsis "Rearrange PDF pages to print as flyers on one sheet")
(description "@command{flyer-composer} can be used to prepare one- or
@@ -302,7 +302,7 @@ When present, Poppler is able to correctly render CJK and Cyrillic text.")
(define-public poppler-qt5
(package/inherit poppler
(name "poppler-qt5")
- (inputs `(("qtbase" ,qtbase)
+ (inputs `(("qtbase" ,qtbase-5)
,@(package-inputs poppler)))
(synopsis "Qt5 frontend for the Poppler PDF rendering library")))
@@ -342,7 +342,7 @@ When present, Poppler is able to correctly render CJK and Cyrillic text.")
`(("python-sip" ,python-sip-4)
("python-pyqt" ,python-pyqt)
("poppler-qt5" ,poppler-qt5)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(home-page "https://pypi.org/project/python-poppler-qt5/")
(synopsis "Python bindings for Poppler-Qt5")
(description
@@ -400,7 +400,7 @@ reading and editing of existing PDF files.")
(inputs `(("cups" ,cups)
("freetype" ,freetype)
("libpng" ,libpng)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("zlib" ,zlib)))
(arguments
`(#:tests? #f)) ; there is no check target
@@ -847,7 +847,7 @@ program capable of converting PDF into other formats.")
("djvulibre" ,djvulibre)
("libspectre" ,libspectre)
("poppler-qt5" ,poppler-qt5)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtsvg" ,qtsvg)))
(arguments
`(#:imported-modules ((guix build qt-build-system)