summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2021-10-21 15:03:57 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-10-22 11:12:18 +0200
commite5f21c7e38fc7c61271e532f434284c94cd6fbb3 (patch)
tree30c72992a13f06976103a41be2801c3db557c75e /gnu/packages/pdf.scm
parentbcad95d0543ecf2e65961a4ce666989821b1be8a (diff)
downloadguix-patches-e5f21c7e38fc7c61271e532f434284c94cd6fbb3.tar
guix-patches-e5f21c7e38fc7c61271e532f434284c94cd6fbb3.tar.gz
gnu: qpdfview: Fix build.
* gnu/packages/pdf.scm (qpdfview)[arguments]: Fix 'configure' phase. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 4ade406b72..042003e898 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -866,9 +866,9 @@ program capable of converting PDF into other formats.")
#:phases
(modify-phases %standard-phases
(replace 'configure
- (lambda _
+ (lambda* (#:key outputs #:allow-other-keys)
(substitute* "qpdfview.pri"
- (("/usr") (assoc-ref %outputs "out")))
+ (("/usr") (assoc-ref outputs "out")))
(invoke "qmake" "qpdfview.pro"))))))
(home-page "https://launchpad.net/qpdfview")
(synopsis "Tabbed document viewer")