summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-03-07 01:37:58 +0100
committerAndreas Enge <andreas@enge.fr>2015-03-07 01:37:58 +0100
commitdde70926568019c1000a1cf7863a3e44433774d7 (patch)
tree286d2f8fbf71c2517bed8e54dc8a5cb1834ebece /gnu/packages/pdf.scm
parentb8ac8c282d9a70949d3f603313b643bfd23b1e32 (diff)
downloadguix-patches-dde70926568019c1000a1cf7863a3e44433774d7.tar
guix-patches-dde70926568019c1000a1cf7863a3e44433774d7.tar.gz
gnu: podofo: Fix detection of freetype.
* gnu/packages/pdf.scm (podofo)[arguments]: Add phase patching the cmake file that looks for freetype.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index f6db546a88..f75a060a4b 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -338,7 +338,16 @@ interaction.")
("zlib" ,zlib)))
(arguments
`(#:configure-flags '("-DPODOFO_BUILD_SHARED=ON"
- "-DPODOFO_BUILD_STATIC=ON")))
+ "-DPODOFO_BUILD_STATIC=ON")
+ #:phases
+ (alist-cons-before
+ 'configure 'patch
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((freetype (assoc-ref inputs "freetype")))
+ ;; Look for freetype include files in the correct place.
+ (substitute* "cmake/modules/FindFREETYPE.cmake"
+ (("/usr/local") freetype))))
+ %standard-phases)))
(home-page "http://podofo.sourceforge.net")
(synopsis "Tools to work with the PDF file format")
(description