summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorangryrectangle@cock.li <angryrectangle@cock.li>2021-11-24 20:21:16 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-25 01:04:17 -0500
commitc9208beb3cbdd592275af28221cb93848b2a71a1 (patch)
tree9618bf0fd33a8ea94a496c30606717f11660613d /gnu/packages/pdf.scm
parent905b090582e5c03ef4fb183fda0a1ababf5cb284 (diff)
downloadguix-patches-c9208beb3cbdd592275af28221cb93848b2a71a1.tar
guix-patches-c9208beb3cbdd592275af28221cb93848b2a71a1.tar.gz
gnu: zathura: Use meson 0.59.
This fixes the build. The problem has already been fixed on the master, but it's not part of the latest release. * gnu/packages/pdf.scm (zathura)[meson]: Use meson-0.59. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index ea19897ae4..dcc314c4fc 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -56,6 +56,7 @@
#:use-module (gnu packages backup)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
+ #:use-module (gnu packages build-tools)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages cups)
@@ -650,7 +651,8 @@ by using the poppler rendering engine.")
(files '("lib/zathura")))))
(build-system meson-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
+ `(#:meson ,meson-0.59
+ #:phases (modify-phases %standard-phases
(add-before 'check 'start-xserver
;; Tests require a running X server.
(lambda* (#:key inputs #:allow-other-keys)