summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-01-28 15:06:54 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-01-28 15:06:54 +0100
commitb9650f7faafc7d691248692d18d99fa54cce5c76 (patch)
tree6098aa352beaadd39fb26c3f378147feca6d23af /gnu/packages/pdf.scm
parent1a0907abd2f3e234e825f14dabc7961d240f30aa (diff)
downloadguix-patches-b9650f7faafc7d691248692d18d99fa54cce5c76.tar
guix-patches-b9650f7faafc7d691248692d18d99fa54cce5c76.tar.gz
gnu: Add extractpdfmark.
* gnu/packages/pdf.scm (extractpdfmark): New variable.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 281dc31c36..66e920a7bb 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -101,6 +101,52 @@
#:use-module (gnu packages xorg)
#:use-module (srfi srfi-1))
+(define-public extractpdfmark
+ (package
+ (name "extractpdfmark")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/trueroad/extractpdfmark")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "14aa6zly53j8gx5d32caiabk2j4b102xha0v9149yahz6kbn5b80"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'start-xorg-server
+ ;; The test suite wants to write to /homeless-shelter
+ (lambda _ (setenv "HOME" (getcwd)))))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gettext" ,gettext-minimal)
+ ("ghostscript" ,ghostscript)
+ ("pkg-config" ,pkg-config)
+ ("texlive" ,texlive-tiny)))
+ (inputs
+ `(("poppler" ,poppler)))
+ (home-page "https://github.com/trueroad/extractpdfmark")
+ (synopsis "Extract page mode and named destinations as PDFmark from PDF")
+ (description
+ "PDFmarks is a technique that accompanies PDF, and that is used to store
+metadata such as author or title, but also structural information such as
+bookmarks or hyperlinks.
+
+When Ghostscript reads the main PDF generated by the TeX system with embedded
+PDF files and outputs the final PDF, the PDF page mode and name targets
+etc. are not preserved. Therefore, when you open the final PDF, it is not
+displayed correctly. Also, remote PDF links do not work correctly.
+
+This program is able to extract the page mode and named targets as PDFmark
+from PDF. In this way, you can obtain embedded PDF files that have kept this
+information.")
+ (license license:gpl3)))
+
(define-public flyer-composer
(package
(name "flyer-composer")