summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-06 00:17:50 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-06 00:17:50 +0100
commitb6f946f039afad6cbc7027d52685072f7fbb8d35 (patch)
tree9dc33d1ef9d307f1e3ed8a825902ff69bbe288f9 /gnu/packages/pdf.scm
parente32aea5472007507e62933b27a4db9a50810e5dc (diff)
parentbc8b2ffdac3f55414629ace5b1a0db32e9656c0a (diff)
downloadguix-patches-b6f946f039afad6cbc7027d52685072f7fbb8d35.tar
guix-patches-b6f946f039afad6cbc7027d52685072f7fbb8d35.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index c065e97da5..5a536141f5 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -226,7 +226,7 @@ When present, Poppler is able to correctly render CJK and Cyrillic text.")
("python-pyqt" ,python-pyqt)
("poppler-qt5" ,poppler-qt5)
("qtbase" ,qtbase)))
- (home-page "https://pypi.python.org/pypi/python-poppler-qt5")
+ (home-page "https://pypi.org/project/python-poppler-qt5/")
(synopsis "Python bindings for Poppler-Qt5")
(description
"This package provides Python bindings for the Qt5 interface of the
@@ -392,7 +392,7 @@ using libspectre.")
(define-public zathura-djvu
(package
(name "zathura-djvu")
- (version "0.2.8")
+ (version "0.2.9")
(source (origin
(method url-fetch)
(uri
@@ -400,7 +400,7 @@ using libspectre.")
version ".tar.xz"))
(sha256
(base32
- "0axkv1crdxn0z44whaqp2ibkdqcykhjnxk7qzms0dp1b67an9rnh"))))
+ "0062n236414db7q7pnn3ccg5111ghxj3407pn9ri08skxskgirln"))))
(native-inputs `(("pkg-config" ,pkg-config)))
(inputs
`(("djvulibre" ,djvulibre)
@@ -472,7 +472,7 @@ by using the @code{mupdf} rendering library.")
(define-public zathura-pdf-poppler
(package
(name "zathura-pdf-poppler")
- (version "0.2.9")
+ (version "0.3.0")
(source (origin
(method url-fetch)
(uri
@@ -480,7 +480,7 @@ by using the @code{mupdf} rendering library.")
version ".tar.xz"))
(sha256
(base32
- "1p4jcny0jniygns78mcf0nlm298dszh49qpmjmackrm6dq8hc25y"))))
+ "1vfl4vkyy3rf39r1sqaa7y8113bgkh2bkfq3nn2inis9mrykmk6m"))))
(native-inputs `(("pkg-config" ,pkg-config)))
(inputs
`(("poppler" ,poppler)
@@ -508,7 +508,7 @@ by using the poppler rendering engine.")
(define-public zathura
(package
(name "zathura")
- (version "0.4.3")
+ (version "0.4.5")
(source (origin
(method url-fetch)
(uri
@@ -516,7 +516,7 @@ by using the poppler rendering engine.")
version ".tar.xz"))
(sha256
(base32
- "0hgx5x09i6d0z45llzdmh4l348fxh1y102sb1w76f2fp4r21j4ky"))))
+ "0b3nrcvykkpv2vm99kijnic2gpfzva520bsjlihaxandzfm9ff8c"))))
(native-inputs `(("pkg-config" ,pkg-config)
("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin")
@@ -1270,13 +1270,13 @@ manipulating PDF documents from the command line. It supports
(define-public weasyprint
(package
(name "weasyprint")
- (version "50")
+ (version "51")
(source
(origin
(method url-fetch)
(uri (pypi-uri "WeasyPrint" version))
(sha256
- (base32 "0invs96zvmcr6wh5klj52jrcnr9qg150v9wpmbhcsf3vv1d1hbcw"))
+ (base32 "0skdzwq7cd715dnnds6abx0k0xmmnmsqp0vb1r1w20sg7abp3sdk"))
(patches (search-patches "weasyprint-library-paths.patch"))))
(build-system python-build-system)
(arguments
@@ -1304,11 +1304,11 @@ manipulating PDF documents from the command line. It supports
(lambda _
(substitute* "setup.cfg"
;; flake8 and isort syntax checks fail, which is not our
- ;; business
+ ;; business.
(("addopts = --flake8 --isort") ""))))
(replace 'check
(lambda _
- ;; run pytest, excluding one failing test
+ ;; Run pytest, excluding one failing test.
(invoke "pytest" "-k" "not test_flex_column_wrap_reverse"))))))
(inputs
`(("fontconfig" ,fontconfig)