summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-07 14:20:54 -0400
committerMark H Weaver <mhw@netris.org>2015-07-07 15:58:35 -0400
commitb1982b80ca8d230d43c514803df726fb0a36a227 (patch)
tree56de46548c64159182e5f15f7d65c4359311b89d /gnu/packages/pdf.scm
parent734976b6816251d2a952856b04793a2d55b4bba3 (diff)
downloadguix-patches-b1982b80ca8d230d43c514803df726fb0a36a227.tar
guix-patches-b1982b80ca8d230d43c514803df726fb0a36a227.tar.gz
gnu: zathura-{cb,ps,djvu,pdf-poppler}: Fix installation of desktop files.
Based on a patch by Alex Kost <alezost@gmail.com>. * gnu/packages/pdf.scm (zathura-cb, zathura-ps, zathura-djvu) (zathura-pdf-poppler)[arguments]: In make-flags, set PREFIX instead of DESTDIR and adjust PLUGINDIR accordingly.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm24
1 files changed, 12 insertions, 12 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 82e8c8884b..541281332d 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -171,9 +171,9 @@
("zathura" ,zathura)))
(build-system gnu-build-system)
(arguments
- `(#:make-flags
- `(,(string-append "DESTDIR=" (assoc-ref %outputs "out"))
- "PLUGINDIR=/lib/zathura" "CC=gcc")
+ `(#:make-flags (list (string-append "PREFIX=" %output)
+ (string-append "PLUGINDIR=" %output "/lib/zathura")
+ "CC=gcc")
#:tests? #f ; Package does not contain tests.
#:phases
(alist-delete 'configure %standard-phases)))
@@ -202,9 +202,9 @@ using libarchive.")
("zathura" ,zathura)))
(build-system gnu-build-system)
(arguments
- `(#:make-flags
- `(,(string-append "DESTDIR=" (assoc-ref %outputs "out"))
- "PLUGINDIR=/lib/zathura" "CC=gcc")
+ `(#:make-flags (list (string-append "PREFIX=" %output)
+ (string-append "PLUGINDIR=" %output "/lib/zathura")
+ "CC=gcc")
#:tests? #f ; Package does not contain tests.
#:phases
(alist-delete 'configure %standard-phases)))
@@ -234,9 +234,9 @@ using libspectre.")
("zathura" ,zathura)))
(build-system gnu-build-system)
(arguments
- `(#:make-flags
- `(,(string-append "DESTDIR=" (assoc-ref %outputs "out"))
- "PLUGINDIR=/lib/zathura" "CC=gcc")
+ `(#:make-flags (list (string-append "PREFIX=" %output)
+ (string-append "PLUGINDIR=" %output "/lib/zathura")
+ "CC=gcc")
#:tests? #f ; Package does not contain tests.
#:phases
(alist-delete 'configure %standard-phases)))
@@ -267,9 +267,9 @@ using the DjVuLibre library.")
("cairo" ,cairo)))
(build-system gnu-build-system)
(arguments
- `(#:make-flags
- `(,(string-append "DESTDIR=" (assoc-ref %outputs "out"))
- "PLUGINDIR=/lib/zathura" "CC=gcc")
+ `(#:make-flags (list (string-append "PREFIX=" %output)
+ (string-append "PLUGINDIR=" %output "/lib/zathura")
+ "CC=gcc")
#:tests? #f ; Package does not include tests.
#:phases
(alist-delete 'configure %standard-phases)))