summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-10 18:15:10 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-11 19:48:31 +0100
commit9df397508dc1bc3544534aebc7c658c9754b08b4 (patch)
tree7a59d005f6f8c691e35e37b6f20a5b5a5bcabfa9 /gnu/packages/pdf.scm
parent35b259eed055e288eadb2365b5ab4e8b15f363a7 (diff)
downloadguix-patches-9df397508dc1bc3544534aebc7c658c9754b08b4.tar
guix-patches-9df397508dc1bc3544534aebc7c658c9754b08b4.tar.gz
gnu: poppler: Update to 0.74.0.
* gnu/packages/patches/scribus-poppler-0.73.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/scribus.scm (scribus)[source](patches): Add it. * gnu/packages/pdf.scm (poppler): Update to 0.74.0. [arguments]: Adjust renamed configure flag. * gnu/packages/tex.scm (texlive-bin)[arguments]: Add phase 'use-code-for-even-newer-poppler'.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 504e69c769..1aa47b5c28 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -83,14 +83,14 @@
(define-public poppler
(package
(name "poppler")
- (version "0.72.0")
+ (version "0.74.0")
(source (origin
(method url-fetch)
(uri (string-append "https://poppler.freedesktop.org/poppler-"
version ".tar.xz"))
(sha256
(base32
- "0lfs1b1jfamxl13zbl5n448dqvl9n8frbv8180y7b7kfyaw7wx61"))))
+ "0bvb0yq9zsl2b811j4l4x0vf8g5lgmqbndkb2hvgsrr5639rzq4j"))))
(build-system cmake-build-system)
;; FIXME:
;; use libcurl: no
@@ -122,7 +122,7 @@
#:configure-flags
(let* ((out (assoc-ref %outputs "out"))
(lib (string-append out "/lib")))
- (list "-DENABLE_XPDF_HEADERS=ON" ; to install header files
+ (list "-DENABLE_UNSTABLE_API_ABI_HEADERS=ON" ;to install header files
"-DENABLE_ZLIB=ON"
(string-append "-DCMAKE_INSTALL_LIBDIR=" lib)
(string-append "-DCMAKE_INSTALL_RPATH=" lib)))))