summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-06-19 17:38:47 +0200
committerMarius Bakke <marius@gnu.org>2021-06-19 17:38:47 +0200
commit6f9a80b331ae41d142a49fbeb94b90ee587b6155 (patch)
tree2da042a6ccf5368c73d6e3d54c2ee02a62d284e4 /gnu/packages/pdf.scm
parent6500c9a5b364616e38a7e03aa4516fc2d7cee876 (diff)
parentdece03e2b98fc1c2428c2448ce5792f813eb79bf (diff)
downloadguix-patches-6f9a80b331ae41d142a49fbeb94b90ee587b6155.tar
guix-patches-6f9a80b331ae41d142a49fbeb94b90ee587b6155.tar.gz
Merge branch 'master' into core-updates
Note: this merge actually changes the 'curl' and 'python-attrs' derivations, as part of solving caf4a7a2770ef4d05a6e18f40d602e51da749ddc and 12964df69a99de6190422c752fef65ef813f3b6b respectively. 4604d43c0e (gnu: gnutls@3.6.16: Fix cross-compilation.) was ignored because it cannot currently be tested. Conflicts: gnu/local.mk gnu/packages/aidc.scm gnu/packages/boost.scm gnu/packages/curl.scm gnu/packages/nettle.scm gnu/packages/networking.scm gnu/packages/python-xyz.scm gnu/packages/tls.scm
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 724f2a7d07..c8d5d78a1d 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -177,7 +177,7 @@ information.")
`(("python-pypdf2" ,python-pypdf2)
("python-pyqt" ,python-pyqt)
("python-poppler-qt5" ,python-poppler-qt5)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(home-page "http://crazy-compilers.com/flyer-composer")
(synopsis "Rearrange PDF pages to print as flyers on one sheet")
(description "@command{flyer-composer} can be used to prepare one- or
@@ -303,7 +303,7 @@ When present, Poppler is able to correctly render CJK and Cyrillic text.")
(define-public poppler-qt5
(package/inherit poppler
(name "poppler-qt5")
- (inputs `(("qtbase" ,qtbase)
+ (inputs `(("qtbase" ,qtbase-5)
,@(package-inputs poppler)))
(synopsis "Qt5 frontend for the Poppler PDF rendering library")))
@@ -343,7 +343,7 @@ When present, Poppler is able to correctly render CJK and Cyrillic text.")
`(("python-sip" ,python-sip-4)
("python-pyqt" ,python-pyqt)
("poppler-qt5" ,poppler-qt5)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(home-page "https://pypi.org/project/python-poppler-qt5/")
(synopsis "Python bindings for Poppler-Qt5")
(description
@@ -401,7 +401,7 @@ reading and editing of existing PDF files.")
(inputs `(("cups" ,cups)
("freetype" ,freetype)
("libpng" ,libpng)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("zlib" ,zlib)))
(arguments
`(#:tests? #f)) ; there is no check target
@@ -848,7 +848,7 @@ program capable of converting PDF into other formats.")
("djvulibre" ,djvulibre)
("libspectre" ,libspectre)
("poppler-qt5" ,poppler-qt5)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtsvg" ,qtsvg)))
(arguments
`(#:imported-modules ((guix build qt-build-system)