summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-01-26 22:50:37 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-01-26 22:50:37 +0100
commit6d80e2644ad5eeb280f228a40823f4a4cd73e0b7 (patch)
tree957a88b835fecec6f20307a9fc9a33bf1e31317b /gnu/packages/pdf.scm
parent1a4f1ea1a3d11fd44b169c7ce23a511ca7b819cb (diff)
downloadguix-patches-6d80e2644ad5eeb280f228a40823f4a4cd73e0b7.tar
guix-patches-6d80e2644ad5eeb280f228a40823f4a4cd73e0b7.tar.gz
gnu: Add img2pdf.
* gnu/packages/pdf.scm (img2pdf): New variable.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index cd368ae413..f9d5bb5c4f 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -93,6 +93,7 @@
#:use-module (gnu packages sqlite)
#:use-module (gnu packages tex)
#:use-module (gnu packages time)
+ #:use-module (gnu packages tcl)
#:use-module (gnu packages tls)
#:use-module (gnu packages web)
#:use-module (gnu packages xdisorg)
@@ -1082,6 +1083,29 @@ such as zooming, highlighting an area of the screen, and a tool to navigate
the PDF pages.")
(license license:gpl2)))
+(define-public img2pdf
+ (package
+ (name "img2pdf")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "img2pdf" version))
+ (sha256
+ (base32 "1jdhmpzgj8815bhargb3xp3ydlqxwkz0mcadrflx2ga0p056kvpa"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pikepdf" ,python-pikepdf)
+ ("python-pillow" ,python-pillow)
+ ("python-tkinter" ,python "tk")))
+ (home-page "https://gitlab.mister-muffin.de/josch/img2pdf")
+ (synopsis "Convert images to PDF via direct JPEG inclusion")
+ (description
+ "img2pdf converts images to PDF via direct JPEG inclusion. That
+conversion is lossless: the image embedded in the PDF has the exact same color
+information for every pixel as the input.")
+ (license license:lgpl3)))
+
(define-public fbida
(package
(name "fbida")