summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-26 18:38:53 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-26 18:39:10 +0100
commit60ba9d8c2c95fa2cc1096ddb718eba88df689123 (patch)
treed99e5f26f6e5ec909658bfadbfe038238ea6613a /gnu/packages/pdf.scm
parent2894bd60db41749fa41baace66f7682ffade3d04 (diff)
downloadguix-patches-60ba9d8c2c95fa2cc1096ddb718eba88df689123.tar
guix-patches-60ba9d8c2c95fa2cc1096ddb718eba88df689123.tar.gz
gnu: pdfposter: Update to 0.7.post1.
* gnu/packages/pdf.scm (pdfposter): Update to 0.7.post1. [source]<pyi-uri> Remove extra file extension. [arguments]: No longer use python-2. Update comment. [inputs]: Replace PyPDF by PyPDF2.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 8afa99a901..609e75b28c 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -1027,20 +1027,18 @@ PDF Arranger was formerly known as PDF-Shuffler.")
(define-public pdfposter
(package
(name "pdfposter")
- (version "0.6.0")
+ (version "0.7.post1")
(source (origin
(method url-fetch)
- (uri (pypi-uri "pdftools.pdfposter" version ".tar.bz2"))
+ (uri (pypi-uri "pdftools.pdfposter" version))
(sha256
(base32
- "1i9jqawf279va089ykicglcq4zlsnwgcnsdzaa8vnm836lqhywma"))))
+ "0c1avpbr9q53yzq5ar2x485rmp9d0l3z27aham32bg7gplzd7w0j"))))
(build-system python-build-system)
(arguments
- `(#:tests? #f ; no test suite, only for visual control
- #:python ,python-2))
+ `(#:tests? #f)) ; test-suite not included in source archive
(inputs
- ;; pdfposter 0.6.0 still uses the old pyPdf
- `(("python2-pypdf" ,python2-pypdf)))
+ `(("python-pypdf2" ,python-pypdf2)))
(home-page "https://pythonhosted.org/pdftools.pdfposter/")
(synopsis "Scale and tile PDF images/pages to print on multiple pages")
(description "@command{pdfposter} can be used to create a large poster by