summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-09-19 18:09:29 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-09-19 18:10:39 +0000
commit57c57f854114b89ba5cd7b3aaa8edd779928f506 (patch)
treebd6d74a0be5fb078e67b86ab34d4778d2fc4fc05 /gnu/packages/pdf.scm
parent02a585212f34a7c6058c40db5a7fed5a4a9b0138 (diff)
downloadguix-patches-57c57f854114b89ba5cd7b3aaa8edd779928f506.tar
guix-patches-57c57f854114b89ba5cd7b3aaa8edd779928f506.tar.gz
gnu: fbida: Fix build.
* gnu/packages/pdf.scm (fbida)[arguments]<#:phases>: Add a 'set-fcommon phase. Also wrap some lines and remove an empty one.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 8e2cebe490..859bb1da39 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -1136,10 +1136,14 @@ information for every pixel as the input.")
(substitute* "mk/Autoconf.mk"
(("/bin/echo") "echo")
(("/sbin/ldconfig -p") "echo lib")) #t))
+ (add-before 'build 'set-fcommon
+ (lambda _
+ (setenv "CFLAGS" "-fcommon")))
(delete 'configure))
#:tests? #f
- #:make-flags (list ,(string-append "CC=" (cc-for-target))
- (string-append "prefix=" (assoc-ref %outputs "out")))))
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "prefix=" (assoc-ref %outputs "out")))))
(inputs `(("libjpeg" ,libjpeg-turbo)
("curl" ,curl)
("libtiff" ,libtiff)
@@ -1161,7 +1165,6 @@ information for every pixel as the input.")
(description
"fbida contains a few applications for viewing and editing images on
the framebuffer.")
-
(license license:gpl2+)))
(define-public pdf2svg