summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2021-02-07 12:40:33 +0100
committerLeo Famulari <leo@famulari.name>2021-02-09 15:38:03 -0500
commit35089dca4053bf5888441d1648086cdadb6eb1e4 (patch)
treeb22842b80c245039d1011b5a62b5cfee36aac544 /gnu/packages/pdf.scm
parent3aba721da73fbdc3382cc098c41596d5cfbb29eb (diff)
downloadguix-patches-35089dca4053bf5888441d1648086cdadb6eb1e4.tar
guix-patches-35089dca4053bf5888441d1648086cdadb6eb1e4.tar.gz
gnu: Xpdf: Update to 4.03.
* gnu/packages/pdf.scm (xpdf): Update to 4.03. [source]: Update URL. [build-system]: Use cmake-build-system. [arguments]: Remove #:parallel-build?, #:configure-flags and #:phases. [inputs]: Add cups, freetype & qtbase. Remove gs-fonts, lesstif, libpaper libx11, libxext, libxp, libxpm & libxt. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm42
1 files changed, 8 insertions, 34 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 3063aa10c0..daea7ee8ad 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -396,47 +396,21 @@ reading and editing of existing PDF files.")
(define-public xpdf
(package
(name "xpdf")
- (version "4.02")
+ (version "4.03")
(source
(origin
(method url-fetch)
- (uri (string-append "https://xpdfreader-dl.s3.amazonaws.com/xpdf-"
- version "4.02.tar.gz"))
+ (uri (string-append "https://dl.xpdfreader.com/xpdf-" version ".tar.gz"))
(sha256
- (base32 "1rbp54mr3z2x3a3a1qmz8byzygzi223vckfam9ib5g1sfds0qf8i"))))
- (build-system gnu-build-system)
- (inputs `(("freetype" ,freetype)
- ("gs-fonts" ,gs-fonts)
- ("lesstif" ,lesstif)
- ("libpaper" ,libpaper)
- ("libx11" ,libx11)
- ("libxext" ,libxext)
- ("libxp" ,libxp)
- ("libxpm" ,libxpm)
- ("libxt" ,libxt)
+ (base32 "0ip81c9vy0igjnasl9iv2lz214fb01vvvdzbvjmgwc63fi1jgr0g"))))
+ (build-system cmake-build-system)
+ (inputs `(("cups" ,cups)
+ ("freetype" ,freetype)
("libpng" ,libpng)
+ ("qtbase" ,qtbase)
("zlib" ,zlib)))
(arguments
- `(#:tests? #f ; there is no check target
- #:parallel-build? #f ; build fails randomly on 8-way machines
- #:configure-flags
- (list (string-append "--with-freetype2-includes="
- (assoc-ref %build-inputs "freetype")
- "/include/freetype2"))
- #:phases
- (modify-phases %standard-phases
- (replace 'install
- (lambda* (#:key outputs inputs #:allow-other-keys #:rest args)
- (let* ((install (assoc-ref %standard-phases 'install))
- (out (assoc-ref outputs "out"))
- (xpdfrc (string-append out "/etc/xpdfrc"))
- (gs-fonts (assoc-ref inputs "gs-fonts")))
- (apply install args)
- (substitute* xpdfrc
- (("/usr/local/share/ghostscript/fonts")
- (string-append gs-fonts "/share/fonts/type1/ghostscript"))
- (("#fontFile") "fontFile")))
- #t)))))
+ `(#:tests? #f)) ; there is no check target
(synopsis "Viewer for PDF files based on the Motif toolkit")
(description
"Xpdf is a viewer for Portable Document Format (PDF) files.")