summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-07-28 18:34:59 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-07-28 18:34:59 +0200
commit1af575f04df6cfb6e5e3f3273271383b6ee355a8 (patch)
tree0f1dfaed352dcdb9c827ed32db267bc7ed3d8203 /gnu/packages/pdf.scm
parent3b6f8a45d725dd7592634a34e8ffbc14a3bd31cc (diff)
parent48d7ac175f69fea587eaa0358eddb5c76205e8ad (diff)
downloadguix-patches-1af575f04df6cfb6e5e3f3273271383b6ee355a8.tar
guix-patches-1af575f04df6cfb6e5e3f3273271383b6ee355a8.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm56
1 files changed, 11 insertions, 45 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index de680f4990..03b311da14 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -169,43 +169,6 @@ When present, Poppler is able to correctly render CJK and Cyrillic text.")
,@(package-inputs poppler)))
(synopsis "Qt5 frontend for the Poppler PDF rendering library")))
-(define-public python-poppler-qt4
- (package
- (name "python-poppler-qt4")
- (version "0.24.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://pypi.python.org/packages/source/p"
- "/python-poppler-qt4/python-poppler-qt4-"
- version ".tar.gz"))
- (sha256
- (base32
- "0x63niylkk4q3h3ay8zrk3m1xiik0x3hlr4gvj7kswx48qi1vb99"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after
- 'unpack 'patch-poppler-include-paths
- (lambda _
- (substitute* (find-files "." "poppler-.*\\.sip")
- (("qt4/poppler-.*\\.h" header)
- (string-append "poppler/" header)))
- #t)))))
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (inputs
- `(("python-sip" ,python-sip)
- ("python-pyqt-4" ,python-pyqt-4)
- ("poppler-qt4" ,poppler-qt4)))
- (home-page "https://pypi.python.org/pypi/python-poppler-qt4")
- (synopsis "Python bindings for Poppler-Qt4")
- (description
- "This package provides Python bindings for the Qt4 interface of the
-Poppler PDF rendering library.")
- (license license:lgpl2.1+)))
-
(define-public python-poppler-qt5
(package
(name "python-poppler-qt5")
@@ -585,23 +548,26 @@ interaction.")
(define-public podofo
(package
(name "podofo")
- (version "0.9.5")
+ (version "0.9.6")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/podofo/podofo/" version
"/podofo-" version ".tar.gz"))
(sha256
(base32
- "012kgfx5j5n6w4zkc1d290d2cwjk60jhzsjlr2x19g3yi75q2jc5"))))
+ "0wj0y4zcmj4q79wrn3vv3xq4bb0vhhxs8yifafwy9f2sjm83c5p9"))))
(build-system cmake-build-system)
- (inputs ; TODO: Add cppunit for tests
- `(("lua" ,lua-5.1)
- ("libpng" ,libpng)
- ("openssl" ,openssl)
- ("fontconfig" ,fontconfig)
+ (native-inputs
+ `(("cppunit" ,cppunit)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libjpeg" ,libjpeg)
("libtiff" ,libtiff)
- ("libjpeg" ,libjpeg-8)
+ ("fontconfig" ,fontconfig)
("freetype" ,freetype)
+ ("libpng" ,libpng)
+ ("lua" ,lua-5.1)
+ ("openssl" ,openssl)
("zlib" ,zlib)))
(arguments
`(#:configure-flags '("-DPODOFO_BUILD_SHARED=ON"