summaryrefslogtreecommitdiff
path: root/gnu/packages/pcre.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-04-06 23:27:10 +0200
committerLudovic Courtès <ludo@gnu.org>2016-04-06 23:27:10 +0200
commita7681d29dcb415593a06cf265aabc776bd3a02c0 (patch)
tree2049996438046498b71f863e859f69ade23556f5 /gnu/packages/pcre.scm
parenta70a50048bec0ba2a694ad2f8f414051e2f88430 (diff)
downloadguix-patches-a7681d29dcb415593a06cf265aabc776bd3a02c0.tar
guix-patches-a7681d29dcb415593a06cf265aabc776bd3a02c0.tar.gz
gnu: pcre: Fix CVE-2016-3191.
* gnu/packages/pcre.scm (pcre)[replacement]: New field. (pcre-fixed): New variable. * gnu/packages/patches/pcre-CVE-2016-3191.patch: New file. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/pcre.scm')
-rw-r--r--gnu/packages/pcre.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/pcre.scm b/gnu/packages/pcre.scm
index d2933bbe38..9794def4c1 100644
--- a/gnu/packages/pcre.scm
+++ b/gnu/packages/pcre.scm
@@ -22,6 +22,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages compression)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu))
@@ -30,6 +31,7 @@
(package
(name "pcre")
(version "8.38")
+ (replacement pcre-fixed)
(source (origin
(method url-fetch)
(uri (list
@@ -65,6 +67,13 @@ POSIX regular expression API.")
(license license:bsd-3)
(home-page "http://www.pcre.org/")))
+(define pcre-fixed ;for CVE-2016-3191
+ (package
+ (inherit pcre)
+ (source (origin
+ (inherit (package-source pcre))
+ (patches (list (search-patch "pcre-CVE-2016-3191.patch")))))))
+
(define-public pcre2
(package
(name "pcre2")