summaryrefslogtreecommitdiff
path: root/gnu/packages/pcre.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-03-07 15:58:26 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-03-07 23:21:22 +0100
commit9bb766e70d03164cb902122f3bbfbf46547f6cda (patch)
treee1bb6df90cdf114b43142c8c87164c80f4c5dcda /gnu/packages/pcre.scm
parent3391e2a0783ee098b7f521ef54a469f025805293 (diff)
downloadguix-patches-9bb766e70d03164cb902122f3bbfbf46547f6cda.tar
guix-patches-9bb766e70d03164cb902122f3bbfbf46547f6cda.tar.gz
gnu: pcre2: Update to 10.23.
* gnu/packages/pcre.scm (pcre2): Update to 10.23. [source]: Remove patch. [arguments]: Add phase to substitute /bin/echo reference. * gnu/packages/patches/pcre2-CVE-2016-3191.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/pcre.scm')
-rw-r--r--gnu/packages/pcre.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/pcre.scm b/gnu/packages/pcre.scm
index fe9157af12..8b92e47a4d 100644
--- a/gnu/packages/pcre.scm
+++ b/gnu/packages/pcre.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -73,16 +74,15 @@ POSIX regular expression API.")
(define-public pcre2
(package
(name "pcre2")
- (version "10.21")
+ (version "10.23")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/pcre/pcre2/"
version "/pcre2-" version ".tar.bz2"))
- (patches (search-patches "pcre2-CVE-2016-3191.patch"))
(sha256
(base32
- "1q6lrj9b08l1q39vxipb0fi88x6ybvkr6439h8bjb9r8jd81fsn6"))))
+ "0vn5g0mkkp99mmzpissa06hpyj6pk9s4mlwbjqrjvw3ihy8rpiyz"))))
(build-system gnu-build-system)
(inputs `(("bzip2" ,bzip2)
("readline" ,readline)
@@ -95,7 +95,14 @@ POSIX regular expression API.")
"--enable-unicode-properties"
"--enable-pcre2-16"
"--enable-pcre2-32"
- "--enable-jit")))
+ "--enable-jit")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-paths
+ (lambda _
+ (substitute* "RunGrepTest"
+ (("/bin/echo") (which "echo")))
+ #t)))))
(synopsis "Perl Compatible Regular Expressions")
(description
"The PCRE library is a set of functions that implement regular expression