summaryrefslogtreecommitdiff
path: root/gnu/packages/pcre.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-12-10 15:56:00 -0500
committerMark H Weaver <mhw@netris.org>2014-12-12 08:56:56 -0500
commit90dcf9c8c5e9d9cf7faf9bbc257bde804016e3b6 (patch)
treedfba27406267d08bd6c905edebaebc3b08cda346 /gnu/packages/pcre.scm
parent8a3c54e0a14b74dabe48943c25fd711d32e91f31 (diff)
downloadguix-patches-90dcf9c8c5e9d9cf7faf9bbc257bde804016e3b6.tar
guix-patches-90dcf9c8c5e9d9cf7faf9bbc257bde804016e3b6.tar.gz
gnu: pcre: Update to 8.36 and enable JIT support.
* gnu/packages/pcre.scm (pcre): Update to 8.36. Enable JIT support.
Diffstat (limited to 'gnu/packages/pcre.scm')
-rw-r--r--gnu/packages/pcre.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/pcre.scm b/gnu/packages/pcre.scm
index 54a3e2277c..3181ba7592 100644
--- a/gnu/packages/pcre.scm
+++ b/gnu/packages/pcre.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -27,14 +28,14 @@
(define-public pcre
(package
(name "pcre")
- (version "8.32")
+ (version "8.36")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/pcre/pcre/"
version "/pcre-" version ".tar.bz2"))
(sha256
(base32
- "0m8gvrf1q0iwll4csirvvj98xygw4cy7r14i5l53ivsqs2dzn4x9"))))
+ "1fs5p1z67m9f4xnyil3s4lhgyld78f7m4d1yawpyhh0cvrbk90zg"))))
(build-system gnu-build-system)
(inputs `(("bzip2" ,bzip2)
("readline" ,readline)
@@ -43,7 +44,8 @@
`(#:configure-flags '("--enable-utf"
"--enable-pcregrep-libz"
"--enable-pcregrep-libbz2"
- "--enable-pcretest-libreadline")))
+ "--enable-pcretest-libreadline"
+ "--enable-jit")))
(synopsis "Perl Compatible Regular Expressions")
(description
"The PCRE library is a set of functions that implement regular expression