summaryrefslogtreecommitdiff
path: root/gnu/packages/pcre.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-28 18:23:28 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-28 18:23:31 +0100
commit8297ff0f931a677c51ca7c64a844a55cd6cd2ef4 (patch)
tree288e5e6e3bf0e8dfc8d10aacd612941455fb486a /gnu/packages/pcre.scm
parent3d185f5562291ca2879fc703dbe61ed99fa929ad (diff)
downloadguix-patches-8297ff0f931a677c51ca7c64a844a55cd6cd2ef4.tar
guix-patches-8297ff0f931a677c51ca7c64a844a55cd6cd2ef4.tar.gz
gnu: pcre2: Update to 10.31.
* gnu/packages/pcre.scm (pcre2): Update to 10.31. [source]: Remove upstreamed patches. * gnu/packages/patches/pcre2-CVE-2017-7186.patch: Delete this file... * gnu/packages/patches/pcre2-CVE-2017-8786.patch: ...and this one. * gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/pcre.scm')
-rw-r--r--gnu/packages/pcre.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/pcre.scm b/gnu/packages/pcre.scm
index ee853d5015..5719b7bb45 100644
--- a/gnu/packages/pcre.scm
+++ b/gnu/packages/pcre.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -75,7 +76,7 @@ POSIX regular expression API.")
(define-public pcre2
(package
(name "pcre2")
- (version "10.23")
+ (version "10.31")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/pcre/pcre2/"
@@ -83,9 +84,7 @@ POSIX regular expression API.")
(sha256
(base32
- "0vn5g0mkkp99mmzpissa06hpyj6pk9s4mlwbjqrjvw3ihy8rpiyz"))
- (patches (search-patches "pcre2-CVE-2017-7186.patch"
- "pcre2-CVE-2017-8786.patch"))))
+ "1b389pzw91k1hzydsh4smdsxyppwz4pv74m3nrvy8rda0j3m6zg0"))))
(build-system gnu-build-system)
(inputs `(("bzip2" ,bzip2)
("readline" ,readline)