summaryrefslogtreecommitdiff
path: root/gnu/packages/pciutils.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-05-29 21:50:27 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-05-29 22:07:47 +0300
commit0ef7a93d78b72153da168d4c356e5789f99f0869 (patch)
treed4c44d73c35f72f5043049898b5e7d9efd50c68e /gnu/packages/pciutils.scm
parentfb3c855381eba87725da33fbd936bb9734a40ccf (diff)
downloadguix-patches-0ef7a93d78b72153da168d4c356e5789f99f0869.tar
guix-patches-0ef7a93d78b72153da168d4c356e5789f99f0869.tar.gz
gnu: pciutils: Use 'modify-phases'.
* gnu/packages/pciutils.scm (pciutils)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/pciutils.scm')
-rw-r--r--gnu/packages/pciutils.scm52
1 files changed, 25 insertions, 27 deletions
diff --git a/gnu/packages/pciutils.scm b/gnu/packages/pciutils.scm
index 9da56ca5e8..3f8d8e9121 100644
--- a/gnu/packages/pciutils.scm
+++ b/gnu/packages/pciutils.scm
@@ -40,33 +40,31 @@
"0byl2f897w5lhs4bvr6p7qwcz9bllj2zyfv7nywbcbsnb9ha9wrb"))))
(build-system gnu-build-system)
(arguments
- '(#:phases (alist-replace
- 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- ;; There's no 'configure' script, just a raw makefile.
- (substitute* "Makefile"
- (("^PREFIX=.*$")
- (string-append "PREFIX := " (assoc-ref outputs "out")
- "\n"))
- (("^MANDIR:=.*$")
- ;; By default the thing tries to automatically
- ;; determine whether to use $prefix/man or
- ;; $prefix/share/man, and wrongly so.
- (string-append "MANDIR := " (assoc-ref outputs "out")
- "/share/man\n"))
- (("^SHARED=.*$")
- ;; Build libpciutils.so.
- "SHARED := yes\n")
- (("^ZLIB=.*$")
- ;; Ask for zlib support.
- "ZLIB := yes\n")))
-
- (alist-replace
- 'install
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Install the commands, library, and .pc files.
- (zero? (system* "make" "install" "install-lib")))
- %standard-phases))
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; There's no 'configure' script, just a raw makefile.
+ (substitute* "Makefile"
+ (("^PREFIX=.*$")
+ (string-append "PREFIX := " (assoc-ref outputs "out")
+ "\n"))
+ (("^MANDIR:=.*$")
+ ;; By default the thing tries to automatically
+ ;; determine whether to use $prefix/man or
+ ;; $prefix/share/man, and wrongly so.
+ (string-append "MANDIR := " (assoc-ref outputs "out")
+ "/share/man\n"))
+ (("^SHARED=.*$")
+ ;; Build libpciutils.so.
+ "SHARED := yes\n")
+ (("^ZLIB=.*$")
+ ;; Ask for zlib support.
+ "ZLIB := yes\n"))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Install the commands, library, and .pc files.
+ (zero? (system* "make" "install" "install-lib")))))
;; Make sure programs have an RPATH so they can find libpciutils.so.
#:make-flags (list (string-append "LDFLAGS=-Wl,-rpath="