summaryrefslogtreecommitdiff
path: root/gnu/packages/patchutils.scm
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-09-12 10:45:27 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-21 15:15:52 +0200
commit94d2d0b7f861803c6670252253e97b266de5514b (patch)
treeaec6ec0231ce3db5fae3325a7a98604a600645df /gnu/packages/patchutils.scm
parent3d15a19874f63dfc15eb6625558f279ccbc71d5d (diff)
downloadguix-patches-94d2d0b7f861803c6670252253e97b266de5514b.tar
guix-patches-94d2d0b7f861803c6670252253e97b266de5514b.tar.gz
gnu: patchutils: Update to 0.4.2.
* gnu/packages/patchutils.scm (patchutils): Update to 0.4.2. [source]: Remove patch. [inputs]: Add ‘python’. [arguments]<#:phases>: Remove trailing #t. * gnu/local.mk (dist_patch_DATA): Remove patch. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patchutils.scm')
-rw-r--r--gnu/packages/patchutils.scm26
1 files changed, 13 insertions, 13 deletions
diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index 8758fb0e8f..6eaf0e371c 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2015, 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Christopher Baines <mail@cbaines.net>
+;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -52,18 +53,19 @@
(define-public patchutils
(package
(name "patchutils")
- (version "0.3.4")
+ (version "0.4.2")
(source
(origin
- (method url-fetch)
- (uri (string-append "http://cyberelk.net/tim/data/patchutils/stable/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "0xp8mcfyi5nmb5a2zi5ibmyshxkb1zv1dgmnyn413m7ahgdx8mfg"))
- (patches (search-patches "patchutils-test-perms.patch"))))
+ (method url-fetch)
+ (uri (string-append "http://cyberelk.net/tim/data/patchutils/stable/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1va5pzmxbzpi87vdnbjm9qdf9bvzps9xfv0gi4mycgg3bybb0xc8"))))
(build-system gnu-build-system)
- (inputs `(("perl" ,perl)))
+ (inputs
+ `(("perl" ,perl)
+ ("python" ,python)))
(arguments
'(#:parallel-tests? #f
#:phases
@@ -71,8 +73,7 @@
(add-before 'check 'patch-test-scripts
(lambda _
(substitute* (find-files "tests" "^run-test$")
- (("/bin/echo") (which "echo")))
- #t))
+ (("/bin/echo") (which "echo")))))
(add-after 'install 'wrap-program
;; Point installed scripts to the utilities they need.
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -87,8 +88,7 @@
,(map (lambda (dir)
(string-append dir "/bin"))
(list diffutils sed gawk)))))
- '("dehtmldiff" "editdiff" "espdiff")))
- #t)))))
+ '("dehtmldiff" "editdiff" "espdiff"))))))))
(home-page "http://cyberelk.net/tim/software/patchutils")
(synopsis "Collection of tools for manipulating patch files")
(description