summaryrefslogtreecommitdiff
path: root/gnu/packages/patchutils.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/patchutils.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/patchutils.scm')
-rw-r--r--gnu/packages/patchutils.scm39
1 files changed, 15 insertions, 24 deletions
diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index 56ea05efdc..0dd7e0450f 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -64,8 +64,7 @@
"1va5pzmxbzpi87vdnbjm9qdf9bvzps9xfv0gi4mycgg3bybb0xc8"))))
(build-system gnu-build-system)
(inputs
- `(("perl" ,perl)
- ("python" ,python)))
+ (list perl python))
(arguments
'(#:parallel-tests? #f
#:phases
@@ -112,11 +111,7 @@ listing the files modified by a patch.")
(build-system gnu-build-system)
(native-inputs
`(("gettext" ,gettext-minimal)))
- (inputs `(("perl" ,perl)
- ("less" ,less)
- ("file" ,file)
- ("ed" ,ed)
- ("diffstat" ,diffstat)))
+ (inputs (list perl less file ed diffstat))
(arguments
'(#:parallel-tests? #f
#:phases
@@ -183,8 +178,7 @@ refreshed, and more.")
(delete 'configure) ; no configure script
(delete 'build)))) ; nothing to build
(inputs
- `(("perl" ,perl)
- ("xmlto" ,xmlto)))
+ (list perl xmlto))
(home-page "https://www.colordiff.org")
(synopsis "Display diff output with colors")
(description
@@ -208,7 +202,7 @@ refreshed, and more.")
"11rdmhv0l1s8nqb20ywmw2zqizczch2p62qf9apyx5wqgxlnjshk"))
(file-name (string-append name "-"version "-checkout"))))
(build-system python-build-system)
- (inputs `(("python-notmuch" ,python2-notmuch)))
+ (inputs (list python2-notmuch))
(arguments
`(#:tests? #f ;no "test" target
#:python ,python-2)) ;not compatible with Python 3
@@ -234,7 +228,7 @@ the command-line or from Emacs via its Notmuch integration.")
"1f1kj4jki08bnrwpzi663mjfkrx4wnfpzdfwd2qgijlkx5ysjkgh"))))
(build-system gnu-build-system)
(inputs
- `(("ncurses" ,ncurses)))
+ (list ncurses))
(home-page "https://www.cjmweb.net/vbindiff/")
(synopsis "Console-based tool for comparing binary data")
(description "Visual Binary Diff (@command{vbindiff}) displays files in
@@ -267,7 +261,7 @@ GiB).")
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("gtksourceview" ,gtksourceview-3)))
(propagated-inputs
- `(("dconf" ,dconf)))
+ (list dconf))
(arguments
`(#:imported-modules ((guix build glib-or-gtk-build-system)
,@%python-build-system-modules)
@@ -459,15 +453,15 @@ if __name__ == \"__main__\":
(chmod (string-append out "/bin/patchwork-admin") #o555))
#t)))))
(inputs
- `(("python-wrapper" ,python-wrapper)))
+ (list python-wrapper))
(propagated-inputs
- `(("python-django" ,python-django-2.2)
- ;; TODO: Make this configurable
- ("python-psycopg2" ,python-psycopg2)
- ("python-mysqlclient" ,python-mysqlclient)
- ("python-django-filter" ,python-django-filter)
- ("python-djangorestframework" ,python-djangorestframework)
- ("python-django-debug-toolbar" ,python-django-debug-toolbar)))
+ (list python-django-2.2
+ ;; TODO: Make this configurable
+ python-psycopg2
+ python-mysqlclient
+ python-django-filter
+ python-djangorestframework
+ python-django-debug-toolbar))
(synopsis "Web based patch tracking system")
(description
"Patchwork is a patch tracking system. It takes in emails containing
@@ -518,10 +512,7 @@ Users can login allowing them to change the state of patches.")
"/share/man/man1"))
#t)))))
(native-inputs
- `(("python-pbr" ,python-pbr)
- ("python-pytest" ,python-pytest)
- ("python-pytest-cov" ,python-pytest-cov)
- ("python-mock" ,python-mock)))
+ (list python-pbr python-pytest python-pytest-cov python-mock))
(home-page
"https://github.com/getpatchwork/pwclient")
(synopsis "Command-line client for the Patchwork patch tracking tool")