summaryrefslogtreecommitdiff
path: root/gnu/packages/patchutils.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-04-27 23:43:36 +0200
committerLudovic Courtès <ludo@gnu.org>2016-04-27 23:43:36 +0200
commit5ca54f41a03f9116822fbe51bb598cc18188bd0d (patch)
treeeb7569de786f14019930fd839eceb1a710290ca2 /gnu/packages/patchutils.scm
parenta17417a812614eee2a7e39155712d7efe814f559 (diff)
downloadguix-patches-5ca54f41a03f9116822fbe51bb598cc18188bd0d.tar
guix-patches-5ca54f41a03f9116822fbe51bb598cc18188bd0d.tar.gz
gnu: patches: Update to latest revision.
* gnu/packages/patchutils.scm (patches): Change URL to the repository of Stefan Hajnoczi, and update to latest revision.
Diffstat (limited to 'gnu/packages/patchutils.scm')
-rw-r--r--gnu/packages/patchutils.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index c4232cc8a7..42da56194c 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -177,24 +177,25 @@ refreshed, and more.")
(license gpl2+)))
(define-public patches
- (let ((commit "26d7dbc"))
+ (let ((commit "ef1b8a7d954b82ed4af3a08fd63d2085d19090ef"))
(package
(name "patches")
- (version (string-append "0.0." commit))
+ (home-page "https://github.com/stefanha/patches")
+ (version (string-append "0.0-1." (string-take commit 7)))
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/aliguori/patches")
+ (url home-page)
(commit commit)))
(sha256
(base32
- "1bah6y84nlii5yif189ns28dz1m9vmsyw66jyk2vr5yf0njf7mzh"))))
+ "11rdmhv0l1s8nqb20ywmw2zqizczch2p62qf9apyx5wqgxlnjshk"))
+ (file-name (string-append name "-"version "-checkout"))))
(build-system python-build-system)
(inputs `(("python-notmuch" ,python2-notmuch)))
(arguments
`(#:tests? #f ;no "test" target
- #:python ,python-2)) ;not compatible with Python 3
- (home-page "https://github.com/aliguori/patches")
+ #:python ,python-2)) ;not compatible with Python 3
(synopsis "Patch tracking tool")
(description
"'Patches' is a patch-tracking tool initially written for the QEMU