summaryrefslogtreecommitdiff
path: root/gnu/packages/patchutils.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-09-12 12:55:49 +0200
committerMarius Bakke <marius@gnu.org>2020-09-22 18:42:00 +0200
commit37c24c0bd04b099c7d3ef5a251a453ad12373c0e (patch)
treebdcf8c53318b69e262289e62cc69e1679e46672e /gnu/packages/patchutils.scm
parent5ec1feca992e84b1cc34cb2d3f24d431b135e633 (diff)
downloadguix-patches-37c24c0bd04b099c7d3ef5a251a453ad12373c0e.tar
guix-patches-37c24c0bd04b099c7d3ef5a251a453ad12373c0e.tar.gz
gnu: patchwork: Update to 2.2.2.
* gnu/packages/patchutils.scm (patchwork): Update to 2.2.2. [arguments]: Remove references to 'pwclient' which is now distributed separately.
Diffstat (limited to 'gnu/packages/patchutils.scm')
-rw-r--r--gnu/packages/patchutils.scm17
1 files changed, 2 insertions, 15 deletions
diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index 335d251e74..12dd472c68 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -321,7 +321,7 @@ you to figure out what is going on in that merge you keep avoiding.")
(define-public patchwork
(package
(name "patchwork")
- (version "2.1.5")
+ (version "2.2.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -330,7 +330,7 @@ you to figure out what is going on in that merge you keep avoiding.")
(file-name (git-file-name name version))
(sha256
(base32
- "1n4hfwlgmw6mj5kp261zfx47mgb0l7g2yzl1rf0rnm8x69lr3as6"))))
+ "1cr3lhm589zhvcgfm8gni036866k2livq1rcxbnigjxlw9p5znaf"))))
(build-system python-build-system)
(arguments
`(;; TODO: Tests require a running database
@@ -396,23 +396,10 @@ application = get_wsgi_application()\n") port)))))
(install-file file (string-append out "/bin")))
(list
(string-append out-site-packages
- "patchwork/bin/pwclient")
- (string-append out-site-packages
"patchwork/bin/parsemail.sh")
(string-append out-site-packages
"patchwork/bin/parsemail-batch.sh")))
- ;; Delete the symlink to pwclient, and replace it with the
- ;; actual file, as this can cause issues when serving the file
- ;; from a webserver.
- (let ((template-pwclient (string-append
- out-site-packages
- "patchwork/templates/patchwork/pwclient")))
- (delete-file template-pwclient)
- (copy-file (string-append out-site-packages
- "patchwork/bin/pwclient")
- template-pwclient))
-
;; Collect the static assets, this includes JavaScript, CSS and
;; fonts. This is a standard Django process when running a
;; Django application for regular use, and includes assets for