summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-06-15 11:33:23 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-06-16 12:13:39 +0200
commitfe197971bba5025f1d9255ad9cfcf91beacd3fac (patch)
tree183a80e6a1f36106e9fd1505963323f93a64d0ba /gnu/packages/patches
parent72a5095e17b3b20ce0244d210a81351a79d32f0f (diff)
downloadguix-patches-fe197971bba5025f1d9255ad9cfcf91beacd3fac.tar
guix-patches-fe197971bba5025f1d9255ad9cfcf91beacd3fac.tar.gz
gnu: bash-completion: Look in user directories first.
* gnu/packages/patches/bash-completion-directories.patch: Move user directories to the head of the list.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/bash-completion-directories.patch4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/patches/bash-completion-directories.patch b/gnu/packages/patches/bash-completion-directories.patch
index 164096f16c..021e34653b 100644
--- a/gnu/packages/patches/bash-completion-directories.patch
+++ b/gnu/packages/patches/bash-completion-directories.patch
@@ -16,11 +16,11 @@ This is what this patch does.
{
- local -a dirs=( ${BASH_COMPLETION_USER_DIR:-${XDG_DATA_HOME:-$HOME/.local/share}/bash-completion}/completions )
+ local -a dirs=(
++ ${BASH_COMPLETION_USER_DIR:-${XDG_DATA_HOME:-$HOME/.local/share}/bash-completion}/completions
+ "$HOME/.guix-profile/share/bash-completion/completions/$base"
+ "$HOME/.guix-profile/etc/bash_completion.d/$base"
+ "/run/current-system/profile/share/bash-completion/completions/$base"
-+ "/run/current-system/profile/etc/bash_completion.d/$base"
-+ ${BASH_COMPLETION_USER_DIR:-${XDG_DATA_HOME:-$HOME/.local/share}/bash-completion}/completions )
++ "/run/current-system/profile/etc/bash_completion.d/$base" )
+
local OIFS=$IFS IFS=: dir cmd="${1##*/}" compfile
for dir in ${XDG_DATA_DIRS:-/usr/local/share:/usr/share}; do