summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-10 20:54:52 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-10 20:54:52 +0100
commitedc8fd2e2d75ba7af9bf6403277ecb0dccd48dc3 (patch)
treeb9da9549c0df1b379536253ef80211138aa9a2d7 /gnu/packages/patches
parent50b99c90c87642f664f9c9523a6e40fc8542ddcf (diff)
downloadguix-patches-edc8fd2e2d75ba7af9bf6403277ecb0dccd48dc3.tar
guix-patches-edc8fd2e2d75ba7af9bf6403277ecb0dccd48dc3.tar.gz
gnu: Remove guile@2.2.6.
* gnu/packages/patches/guile-finalization-crash.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/guile.scm (guile-2.2)[source](patches): Remove 'guile-finalization-crash.patch'. (guile-2.2.7): Remove variable. (guile-2.2/bug-fix): Point to GUILE-2.2. * gnu/packages/admin.scm (shepherd)[native-inputs, inputs]: Use GUILE-2.2 instead of GUILE-2.2.7.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/guile-finalization-crash.patch61
1 files changed, 0 insertions, 61 deletions
diff --git a/gnu/packages/patches/guile-finalization-crash.patch b/gnu/packages/patches/guile-finalization-crash.patch
deleted file mode 100644
index 098249e49f..0000000000
--- a/gnu/packages/patches/guile-finalization-crash.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-commit edf5aea7ac852db2356ef36cba4a119eb0c81ea9
-Author: Ludovic Courtès <ludo@gnu.org>
-Date: Mon Dec 9 14:44:59 2019 +0100
-
- Fix non-deterministic crash in 'finalization_thread_proc'.
-
- Fixes <https://bugs.gnu.org/37757>.
- Reported by Jesse Gibbons <jgibbons2357@gmail.com>.
-
- * libguile/finalizers.c (finalization_thread_proc): Do not enter the
- "switch (data.byte)" condition when data.n <= 0.
-
-diff --git a/libguile/finalizers.c b/libguile/finalizers.c
-index c5d69e8e3..94a6e6b0a 100644
---- a/libguile/finalizers.c
-+++ b/libguile/finalizers.c
-@@ -1,4 +1,4 @@
--/* Copyright (C) 2012, 2013, 2014 Free Software Foundation, Inc.
-+/* Copyright (C) 2012, 2013, 2014, 2019 Free Software Foundation, Inc.
- *
- * This library is free software; you can redistribute it and/or
- * modify it under the terms of the GNU Lesser General Public License
-@@ -211,21 +211,26 @@ finalization_thread_proc (void *unused)
-
- scm_without_guile (read_finalization_pipe_data, &data);
-
-- if (data.n <= 0 && data.err != EINTR)
-+ if (data.n <= 0)
- {
-- perror ("error in finalization thread");
-- return NULL;
-+ if (data.err != EINTR)
-+ {
-+ perror ("error in finalization thread");
-+ return NULL;
-+ }
- }
--
-- switch (data.byte)
-+ else
- {
-- case 0:
-- scm_run_finalizers ();
-- break;
-- case 1:
-- return NULL;
-- default:
-- abort ();
-+ switch (data.byte)
-+ {
-+ case 0:
-+ scm_run_finalizers ();
-+ break;
-+ case 1:
-+ return NULL;
-+ default:
-+ abort ();
-+ }
- }
- }
- }