summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-16 04:39:17 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-16 15:45:34 +0100
commite76cbdcd90e603d98f9d074aa2ee0788c65d97df (patch)
treec3104ed2035e314ed0d967ed1b5ab9c3df601273 /gnu/packages/patches
parent066c21cda4a9893a0cc8398d1a4d3f9f1ac1dfbb (diff)
downloadguix-patches-e76cbdcd90e603d98f9d074aa2ee0788c65d97df.tar
guix-patches-e76cbdcd90e603d98f9d074aa2ee0788c65d97df.tar.gz
gnu: beets: Fix build with newer Werkzeug.
* gnu/packages/patches/beets-werkzeug-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/music.scm (beets)[source](patches): New field.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/beets-werkzeug-compat.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/patches/beets-werkzeug-compat.patch b/gnu/packages/patches/beets-werkzeug-compat.patch
new file mode 100644
index 0000000000..1a91c3a3f9
--- /dev/null
+++ b/gnu/packages/patches/beets-werkzeug-compat.patch
@@ -0,0 +1,18 @@
+Be compatible with python-werkzeug 1.0.0.
+
+Taken from upstream:
+https://github.com/beetbox/beets/commit/d43d54e21cde97f57f19486925ab56b419254cc8
+
+diff --git a/beetsplug/web/__init__.py b/beetsplug/web/__init__.py
+index f53fb3a954..21ff5d94ed 100644
+--- a/beetsplug/web/__init__.py
++++ b/beetsplug/web/__init__.py
+@@ -169,7 +169,7 @@ def to_python(self, value):
+ return ids
+
+ def to_url(self, value):
+- return ','.join(value)
++ return ','.join(str(v) for v in value)
+
+
+ class QueryConverter(PathConverter):