summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-01 16:02:16 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-01 16:31:52 +0100
commite02671939bcc4a38e13f68f58d4cb531150dde81 (patch)
tree6e18f5abd93b5c4a4345a3b4dd32685086dd0a42 /gnu/packages/patches
parentceb831d33841d47f4b92c07829df9134853c83d0 (diff)
downloadguix-patches-e02671939bcc4a38e13f68f58d4cb531150dde81.tar
guix-patches-e02671939bcc4a38e13f68f58d4cb531150dde81.tar.gz
gnu: acl: Update to 2.2.53.
* gnu/packages/patches/acl-hurd-path-max.patch, gnu/packages/patches/acl-fix-perl-regex.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/acl.scm (acl): Update to 2.2.53. [source](uri): Adjust for renamed tarball. [arguments]: Remove #:test-target. Adjust disabled tests. Don't override install phase.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/acl-fix-perl-regex.patch22
-rw-r--r--gnu/packages/patches/acl-hurd-path-max.patch80
2 files changed, 0 insertions, 102 deletions
diff --git a/gnu/packages/patches/acl-fix-perl-regex.patch b/gnu/packages/patches/acl-fix-perl-regex.patch
deleted file mode 100644
index f682abc058..0000000000
--- a/gnu/packages/patches/acl-fix-perl-regex.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-This can be removed with the next acl release
-
----
- test/run | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/test/run b/test/run
-index 2cf52e8..4627cd2 100755
---- a/test/run
-+++ b/test/run
-@@ -70,7 +70,7 @@ for (;;) {
- if (defined $line) {
- # Substitute %VAR and %{VAR} with environment variables.
- $line =~ s[%(\w+)][$ENV{$1}]eg;
-- $line =~ s[%{(\w+)}][$ENV{$1}]eg;
-+ $line =~ s[%\{(\w+)\}][$ENV{$1}]eg;
- }
- if (defined $line) {
- if ($line =~ s/^\s*< ?//) {
---
-2.15.0
-
diff --git a/gnu/packages/patches/acl-hurd-path-max.patch b/gnu/packages/patches/acl-hurd-path-max.patch
deleted file mode 100644
index 89cb3a38d7..0000000000
--- a/gnu/packages/patches/acl-hurd-path-max.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=636512
-
-From: Svante Signell <srs@kth.se>
-Subject: acl: Fix FTBFS on hurd-i386
-Date: Wed, 03 Aug 2011 19:36:27 +0200
-
-Currently acl does not compile on hurd-i386. The problem is a PATH_MAX
-definition which is not supported on GNU/Hurd.
-
-Index: acl-2.2.52/setfacl/parse.c
-===================================================================
---- acl-2.2.52/setfacl/parse.c
-+++ acl-2.2.52/setfacl/parse.c
-@@ -419,7 +419,13 @@ read_acl_comments(
- bytes for "# file: ". Not a good solution but for now it is the
- best I can do without too much impact on the code. [tw]
- */
-+
-+#ifdef __GNU__
-+ char *linebuf;
-+ size_t dummy = 0;
-+#else
- char linebuf[(4*PATH_MAX)+9];
-+#endif
- char *cp;
- char *p;
- int comments_read = 0;
-@@ -449,9 +455,13 @@ read_acl_comments(
- if (line)
- (*line)++;
-
-+#ifdef __GNU__
-+ if (getline(&linebuf, &dummy, file) == -1)
-+ break;
-+#else
- if (fgets(linebuf, sizeof(linebuf), file) == NULL)
- break;
--
-+#endif
- comments_read = 1;
-
- p = strrchr(linebuf, '\0');
-@@ -473,7 +483,12 @@ read_acl_comments(
- goto fail;
- *path_p = (char*)malloc(strlen(cp)+1);
- if (!*path_p)
-+ {
-+#ifdef __GNU__
-+ free (linebuf);
-+#endif
- return -1;
-+ }
- strcpy(*path_p, cp);
- }
- } else if (strncmp(cp, "owner:", 6) == 0) {
-@@ -522,13 +537,24 @@ read_acl_comments(
- }
- }
- if (ferror(file))
-+ {
-+#ifdef __GNU__
-+ free (linebuf);
-+#endif
- return -1;
-+ }
-+#ifdef __GNU__
-+ free (linebuf);
-+#endif
- return comments_read;
- fail:
- if (path_p && *path_p) {
- free(*path_p);
- *path_p = NULL;
- }
-+#ifdef __GNU__
-+ free (linebuf);
-+#endif
- return -EINVAL;
- }
-