summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2021-02-12 15:53:45 -0800
committerVagrant Cascadian <vagrant@debian.org>2021-02-12 16:13:07 -0800
commitd588cc8fa96e4a4bce56fac2ba3bbaaeaaed0047 (patch)
tree63da3320590863608d59e60e1c1b880456e9a42e /gnu/packages/patches
parente69f2e9add408156b6b6e20cda0307037c51b674 (diff)
downloadguix-patches-d588cc8fa96e4a4bce56fac2ba3bbaaeaaed0047.tar
guix-patches-d588cc8fa96e4a4bce56fac2ba3bbaaeaaed0047.tar.gz
gnu: diffoscope: Update to use python-magic.
Fixes: https://salsa.debian.org/reproducible-builds/diffoscope/-/issues/238 * gnu/packages/patches/diffoscope-revert-to-magic-open.patch: Remove file. * gnu/local.mk [dist_patch_DATA]: Update. * gnu/packages/diffoscope.scm (diffoscope)[source]: Remove patch. [inputs]: Remove python-file.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/diffoscope-revert-to-magic-open.patch70
1 files changed, 0 insertions, 70 deletions
diff --git a/gnu/packages/patches/diffoscope-revert-to-magic-open.patch b/gnu/packages/patches/diffoscope-revert-to-magic-open.patch
deleted file mode 100644
index d52b26ead5..0000000000
--- a/gnu/packages/patches/diffoscope-revert-to-magic-open.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-From b658c3a6819ccb9a104b13e973132c66f0965965 Mon Sep 17 00:00:00 2001
-From: Vagrant Cascadian <vagrant@reproducible-builds.org>
-Date: Thu, 11 Feb 2021 17:28:21 -0800
-Subject: [PATCH] Revert "Prefer to use magic.Magic over the magic.open
- compatibility interface. (Closes: reproducible-builds/diffoscope#236)"
-
-This reverts commit c72c30f29ea3760eb4c785644dc7cd4c26833740.
----
- diffoscope/comparators/utils/file.py | 28 ++++++++++++++--------------
- 1 file changed, 14 insertions(+), 14 deletions(-)
-
-diff --git a/diffoscope/comparators/utils/file.py b/diffoscope/comparators/utils/file.py
-index fb3b4316..32700f02 100644
---- a/diffoscope/comparators/utils/file.py
-+++ b/diffoscope/comparators/utils/file.py
-@@ -65,37 +65,37 @@ def _run_tests(fold, tests):
-
-
- class File(metaclass=abc.ABCMeta):
-- if hasattr(magic, "Magic"): # use python-magic
-+ if hasattr(magic, "open"): # use Magic-file-extensions from file
-
- @classmethod
- def guess_file_type(cls, path):
- if not hasattr(cls, "_mimedb"):
-- cls._mimedb = magic.Magic()
-- return maybe_decode(cls._mimedb.from_file(path))
-+ cls._mimedb = magic.open(magic.NONE)
-+ cls._mimedb.load()
-+ return cls._mimedb.file(
-+ path.encode("utf-8", errors="surrogateescape")
-+ )
-
- @classmethod
- def guess_encoding(cls, path):
- if not hasattr(cls, "_mimedb_encoding"):
-- cls._mimedb_encoding = magic.Magic(mime_encoding=True)
-- return maybe_decode(cls._mimedb_encoding.from_file(path))
-+ cls._mimedb_encoding = magic.open(magic.MAGIC_MIME_ENCODING)
-+ cls._mimedb_encoding.load()
-+ return cls._mimedb_encoding.file(path)
-
-- else: # use Magic-file-extensions from file
-+ else: # use python-magic
-
- @classmethod
- def guess_file_type(cls, path):
- if not hasattr(cls, "_mimedb"):
-- cls._mimedb = magic.open(magic.NONE)
-- cls._mimedb.load()
-- return cls._mimedb.file(
-- path.encode("utf-8", errors="surrogateescape")
-- )
-+ cls._mimedb = magic.Magic()
-+ return maybe_decode(cls._mimedb.from_file(path))
-
- @classmethod
- def guess_encoding(cls, path):
- if not hasattr(cls, "_mimedb_encoding"):
-- cls._mimedb_encoding = magic.open(magic.MAGIC_MIME_ENCODING)
-- cls._mimedb_encoding.load()
-- return cls._mimedb_encoding.file(path)
-+ cls._mimedb_encoding = magic.Magic(mime_encoding=True)
-+ return maybe_decode(cls._mimedb_encoding.from_file(path))
-
- def __init__(self, container=None):
- self._comments = []
---
-2.30.0
-